Opened 16 years ago

Closed 15 years ago

Last modified 15 years ago

#1499 closed defect (worksforme)

COMI: Broken subtitles

Reported by: SF/bigmuzzy Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I've launched the game from CD in fullscreen mode with subtitles set to *off* (scummvm --path=E:\ -- fullscreen --no-subtitles comi), selected the Mega Monkey mode, pressed Escape (twice) to skip intro. Then, after "Part I" screen, Guybrush appeared near Wally and started to speak. From time to time broken lines like "here and help Elaine", "ugh this one door...", and "rpower the armed guards above..." appeared. Plus, there were some delays in character and mouse movements, and therefore asynchronization in sound/animation.

It is possible to reproduce this effect, but I can't say how exactly. Say, from about 8 game launches there were 5 with broken subtitles.

But when I've launched it 4-5 times from HDD, everything was OK.

[English version of CoMI; Windows XP SP1; ScummVM 0.6.0pre (Feb 24 2004 12:10:45)]

Ticket imported from: #905014. Ticket imported from: bugs/1499.

Change History (9)

comment:1 by fingolfin, 16 years ago

Can you still reproduce the problem with a current CVS build?

AFAIK there in general troubles with playing games directly from under Windows (using ScummVM at least).

comment:2 by SF/bigmuzzy, 16 years ago

Yes, there still this problem (ScummVM 0.7.0CVS (Apr 5 2004 11:16:49)).

Think, the main problem is that game is running hard from CD (I'm not sure you understand what I want to say - I don't speak English well). When playing CoMI directly from under Windows (w/o ScummVM) everything is OK. So as playing it with ScummVM from HDD.

But of course even if there are "delays in movements", think broken subtitles shouldn't appear, especially in no-subtitles mode.

comment:3 by Kirben, 16 years ago

aquaduan, could you look into this issue ? I noticed imuse digital sometimes falsely reports the talk channel has finished.

comment:4 by Kirben, 16 years ago

Owner: set to aquadran

comment:5 by fingolfin, 16 years ago

Actually, doesn't this fall into the category "playing stuff directly from CD is not supported under Windows" category? :-)

comment:6 by Kirben, 16 years ago

No, I have seen this happen once before too and I always play from hard disk.

comment:7 by fingolfin, 15 years ago

Well, so do you mean you can reproduce this, too, Kirben, or do yuo mean that you once saw this, but never again?

In any case, I don't see what we can do about a problem we (or at least I) can't reproduce at all...

comment:8 by fingolfin, 15 years ago

What is the status of this item?

comment:9 by fingolfin, 15 years ago

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.