Opened 16 years ago

Closed 14 years ago

Last modified 14 years ago

#1487 closed defect (fixed)

COMI: newlines in end credits incorrect (german version)

Reported by: SF/moge Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I found a small bugin the german Version of CoMI.
I played a bit with subtitles enabled, and found some
places where the newline character (\n) seems to be
actually drawn on screen.
I used the latest daily Build for Windows.
A place where this happens is in one of the cutscene
shortly after Guybrush gives the cursed Ring to Elaine
and Wally turns up and tells them that the Ring looks
like the one from LeChucks ship.
In another Cutscene this happens again, shortly after
Guybrush releases the curse. I'll add screenshots of this.
I think the reasons for this is in the file
/resource/language.tab, which seems to contain
translations of all the Strings in the game (but you
should already know that...), and I think all appearing
"\n" are from this file, although there were not meant
to be printed out (and it isn't done in the original game).
For Example the String said by Wally written like this
in the File:
"CRWY140 Hey! Der sieht fast aus, wie der grosse
Diamantring, den LeChuck in seiner\n Schatzkammer hatte."

I think this was made, to tell the original Game where
a new Line should begin.
This might be the case with other versions of the game,
except perhaps the english one.

Ticket imported from: #902415. Ticket imported from: bugs/1487.

Attachments (4)

comi3.jpg (24.1 KB ) - added by SF/moge 16 years ago.
comi1.jpg (25.5 KB ) - added by SF/moge 16 years ago.
comi.s01 (56.8 KB ) - added by SF/moge 15 years ago.
Use the Ring on the Window, and watch the Cutscene with subtitles turned on to see the \n when Wally talks
comi.s02 (75.8 KB ) - added by SF/moge 15 years ago.
Use the Ring on Elaine, and watch the Cutscene with subtitles, to see another Place where \n appears in the Text

Download all attachments as: .zip

Change History (20)

by SF/moge, 16 years ago

Attachment: comi3.jpg added

by SF/moge, 16 years ago

Attachment: comi1.jpg added

comment:1 by SF/moge, 16 years ago

Priority: normallow

comment:2 by SF/bigmuzzy, 16 years ago

I've seen something like this in English version of CoMI. Only
instead of '\n'-s there where those funny square-symbols
which have the meaning of "bad symbol". They appear when
Guybrush is singing to Van Helgen.

[Windows XP SP1; ScummVM 0.6.0pre (Feb 24 2004
12:10:45)]

comment:3 by fingolfin, 16 years ago

I don't think that this is the same issue, bigmuzzy.

The only place I see \n being used in the english version is in a certain
easter egg sequence. It shouldn't be hard to add support for this. BUt
anyway, this is yet another proof that the COMI (and possible Dig/FT)
text drawing system is very much different from the one used in older
Scumm versions, we will have to make even more changes to it...

comment:4 by fingolfin, 16 years ago

It would be very useful if you were able to provide a savegame close to
a place where the issue can be reproduced.

comment:5 by SF/bigmuzzy, 16 years ago

to fingolfin:

Would it be better if I create new bug-thread for "square-
symbols problem" I've mentioned, since it seems that I can't
attach files in foreign threads?

comment:6 by SF/bigmuzzy, 16 years ago

Well, as for my previous post, there _is_ such thread already -
bug 910216.

comment:7 by SF/moge, 16 years ago

I can't attach a Savegame right now, because I'm not at
home right now (visiting my parents until University starts
again next week), so I don't have COMI with me right now.
But one place where that can be reproduced is not too far
into the game. It's in the cutscene when Guybrush gives the
ring to Elaine and Wally says somthing like "Hey, that Ring
looks just like the one from LeChucks treasure".
But when I come home next week, I'll see if i have savegames
at those places.
I looked at the Source code once, but I didn't understand all
of it, but I think the file language.tab is stored into memory,
right? woudn't it then be possible just to skip those two
characters when the file is read into memory?

comment:8 by SF/noscript, 16 years ago

Its in the Credits, too

by SF/moge, 15 years ago

Attachment: comi.s01 added

Use the Ring on the Window, and watch the Cutscene with subtitles turned on to see the \n when Wally talks

by SF/moge, 15 years ago

Attachment: comi.s02 added

Use the Ring on Elaine, and watch the Cutscene with subtitles, to see another Place where \n appears in the Text

comment:9 by SF/moge, 15 years ago

Sorry. I forgot to send the Savegames, but here they are now.
I just checked it with the newest CVS Daily Build
(Downloaded 20 minutes ago) for Windows XP and the problem
is still there...

comment:10 by SF/ketchup_addict, 15 years ago

The same bug ( \n) appears in the french version as well, and
strangely enough it appears to only affect cutscenes
(sometimes in several texts there is also a □after the
sentences you have to pick in dialogues, but since I don't
know if THIS one is related I won't extend).

This have been tested with the last stable version (0.7.1) as
well as the Win32 CVS 0.8.0 snapshot dated 3 April.

comment:11 by fingolfin, 14 years ago

Fixing the issue is rather trivial; I only hesitate because
I wonder what the "proper" fix is. In particular, it would
be interesting to have a screenshots of the respective
scenes using the *original* engine. I.e. a picture where I
can see what the output is supposed to look, so I have a
reference to work on.

Basically, we can choose between just ignoring the \n, or we
can translate it to a newline...

comment:12 by fingolfin, 14 years ago

Owner: set to fingolfin

comment:13 by fingolfin, 14 years ago

I have partially fixed this in CVS now. The fix will only
work for the cutscene/movie/SMUSH cases, though. In
particular, the newlines which occur at the very end of the
end credits in the german version aren't treated properly
yet (they aren't visible anymore, but they have no effect
either). The main reason for that is that I have no idea how
they should work there.

If somebody feels bored: using the original COMI.EXE, go to
the end credits (it's easy to get to them using the Shift-W
'cheat), and wait until almost the end. When you see
"Christian 'Chrisse' Schneider: Regie, Casting, Besetzung",
please make a couple of screenshots.

comment:14 by fingolfin, 14 years ago

Summary: COMI: '\n' printed in subtitles (german Version)COMI: newlines in end credits incorrect (german version)

comment:15 by fingolfin, 14 years ago

Credits are fixed now, too.

comment:16 by fingolfin, 14 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.