Opened 16 years ago

Closed 16 years ago

#1488 closed defect (fixed)

COMI: Long pauses between dialog at Part III

Reported by: SF/monkeybutter Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

At the beginning of Act III, when Rottingham boards the ship
and he and Guybrush fight, they just stand about with swords
out taking long pauses between dialog. There are a lot of
"Remap actor 11 not in current room!" warnings happening at
this point.

ScummVM 0.5.7cvs (Feb 23 2004 19:16:26)
Features compiled in: Vorbis MP3 ALSA zLib
Build: Debian testing/i386
English standard version of CMI

Ticket imported from: #902552. Ticket imported from: bugs/1488.

Change History (9)

comment:1 by SF/monkeybutter, 16 years ago

Summary: Rottingham and Guybrush don't swordfightCOMI: Rottingham and Guybrush don't swordfight

comment:2 by SF/monkeybutter, 16 years ago

It appears I was wrong about the Remap warnings, however I noticed
that the delay between speech sections continues even after the fight.

See bug 902568 for a save game that gets you here.

comment:3 by SF/monkeybutter, 16 years ago

Ok, so maybe they weren't actually sword fighting - I'm getting long
pauses between all sections of dialog after part III starts. '.' skips
through, which mitigates the problem, but the +/- keys do nothing to
change the dialog speed.

comment:4 by SF/monkeybutter, 16 years ago

Summary: COMI: Rottingham and Guybrush don't swordfightCOMI: Long pauses between dialog at Part III

comment:5 by fingolfin, 16 years ago

Owner: set to Kirben

comment:6 by fingolfin, 16 years ago

It's possibly that you got yourself a CVS build which was made in the
middle of the text speed changes we applied to the trunk recently. That
would fit well into what you describe, I believe. Kirben, what do you
think?

I strongly recommend that you either get a 0.6.0pre build (which is the
one we are stabilizing for release), or ge a newer devel build (which
currently is getting lots of changes applied and as such can easily be
broken in numerous ways.

comment:7 by Kirben, 16 years ago

The subtitle speed changes should have been completed by
that time/date. Adjusting the subtitle speed via '-' & '+' keys
would be another way to double check.

comment:8 by Kirben, 16 years ago

Resolution: fixed
Status: newclosed

comment:9 by Kirben, 16 years ago

The problem is VAR_CHARINC works in reverse in COMI, so I
had to add adjustment to readVar.

Note: See TracTickets for help on using tickets.