Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1390 closed defect (duplicate)

DIG: Crashes when trying to open 3rd door in Nexus

Reported by: SF/e-lien Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Hello,

I'm running ScummVM 0.5.7 built on Jan 15 2004under
Windows 2000.

The Dig crashes when I try to open the third door in the
Nexus. That one which rod is to be found in the
underwater cave. The crash happens as soon as the
door open animation starts. ScummVM throws this error
message: "Fatal signal: Segmentation Fault (SDL
Parachute Deployed)".

I attached the savegame to this thread. The most right
item at the door panel should be a green cubic.

Ticket imported from: #877478. Ticket imported from: bugs/1390.

Attachments (1)

dig.s23 (19.1 KB ) - added by SF/e-lien 16 years ago.

Download all attachments as: .zip

Change History (4)

by SF/e-lien, 16 years ago

Attachment: dig.s23 added

comment:1 by SF/e-lien, 16 years ago

Summary: Crashes when trying to open 3rd door in NexusDIG: Crashes when trying to open 3rd door in Nexus

comment:2 by Kirben, 16 years ago

Closed as duplicate of #877478, since it has same cause. See
back trace below:
#0 0x77c42f43 in msvcrt!memcpy () from
C:\WINDOWS\system32\msvcrt.dll
#1 0x00433eb5 in Scumm::ScummEngine::blit(unsigned
char*, unsigned char const*, int, int) (
this=0x13e94f0,
dst=0x2412494 "\eRSRRSSSRRSSSSSSS\eQ\e\032\032
\032PPPPPPPPOOMOOOMLLLJJMLrJJrOOONNOONOOOOONONOP
OOONOOPOOOOPNOONMuttts", 'O' <repeats 16
times>, "PPOPPNNNNNNNNNNMNMMMMMMMLrKNMMMMMMssLM
MLJrMMMMMMMMLrrrrsLtPPOPPNONMMMMOMMMMMNNNMMMM
MNNsssNMMMNN"...,

src=0x24228b4 "wwwwwdC\207J\210ɼ\210c\00
6xww\235\200w\215bw!+wZlw\213\230w\207H\235
\210\207\210h\214\210\230
\210sU\210D:\210Se\210TFx\207\t\b\210\t\axww\207
\017\020\210\n\005\210\006\020\210\021\005\210
\f\tx\b\210\t\r\210\t", w=-845, h=9) at scumm/gfx.cpp:663
#2 0x00433b87 in Scumm::ScummEngine::restoreBG
(Common::Rect, unsigned char) (this=0x13e94f0, rect=
{top = 8, left = 0, bottom = 17, right = -845},
backColor=0 '\0') at scumm/gfx.cpp:577
#3 0x00433c80 in
Scumm::CharsetRenderer::restoreCharsetBg()
(this=0x14ab460) at scumm/gfx.cpp:611
#4 0x00426e42 in Scumm::ScummEngine::stopTalk()
(this=0x13e94f0) at scumm/actor.cpp:1201
#5 0x00460087 in Scumm::ScummEngine::CHARSET_1()
(this=0x13e94f0) at scumm/string.cpp:178
#6 0x0041aea9 in Scumm::ScummEngine::scummLoop(int)
(this=0x13e94f0, delta=5)
at scumm/scummvm.cpp:1495
#7 0x00419b39 in Scumm::ScummEngine::mainRun()
(this=0x13e94f0) at scumm/scummvm.cpp:1256
#8 0x004180cc in Scumm::ScummEngine::go()
(this=0x13e94f0) at scumm/scummvm.cpp:898
#9 0x004069ac in main (argc=3, argv=0x3f25c8) at
base/main.cpp:292

comment:3 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.