Opened 16 years ago

Closed 15 years ago

#1389 closed defect (fixed)

COMI: "Stuttering" voices

Reported by: eriktorbjorn Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

Ever since the new digital iMUSE, most times when a
characer in CMI is speaking the voice "stutters"
slightly at the beginning. I don't know quite how to
explain it, but it's af it goes quiet for a split
second, and then resumes.

Ticket imported from: #877398. Ticket imported from: bugs/1389.

Change History (13)

comment:1 by fingolfin, 16 years ago

That's probably so because "playInputStream" is being called on an
(appendable) stream before the stream contains any data. Result:
is the stutter you see.

comment:2 by fingolfin, 16 years ago

Component: Engine: SCUMM
Game: Monkey Island 3
Owner: set to aquadran
Summary: CMI: "Stuttering" voicesCMI: "Stuttering" voices

comment:3 by fingolfin, 16 years ago

Note also this hack:
if (_track[l].stream->endOfData()) {
mixer_size *= 2;
}
which I originally put in the old imuse_digital.cpp code as a
workaround for the above mentioned bug. Without it, speech would
constantly stutter, because it never will catch up with producing
enough data for what the mixer wants to consume...

All of this wouldn't be necessary if the code was using a custom
AudioStream based on "pulingl". But as long as we "push" the
data, we always run the risk of getting an overflow/underflow.

comment:4 by fingolfin, 16 years ago

Summary: CMI: "Stuttering" voicesCOMI: "Stuttering" voices

comment:5 by SF/evil_penguin, 16 years ago

Verified that this remains with ScummVM 0.6.0pre as of today
(2004-02-20 22:40 CET).

comment:6 by fingolfin, 16 years ago

What is the status of this item?

comment:7 by eriktorbjorn, 16 years ago

Pretty much the same for me. I realize now that "stuttering"
may have given the wrong impression. It's more like a slight
hiccup. The voice starts fine, plays for a fraction of a
second. Then the volume either goes way down or maybe the
sound pauses completely - it's hard to make out - and then
it continues fine again.

It's probably more noticeable to me since I use headphones
right now.

comment:8 by fingolfin, 16 years ago

Summary: COMI: "Stuttering" voicesCOMI: "Stuttering" voices

comment:9 by aquadran, 15 years ago

how it sound currently with latest cvs ?

comment:10 by eriktorbjorn, 15 years ago

Better... and worse. :-)

To explain, the stutter/hiccup does seem to be gone now. On
the other hand, characters often start speaking the next
line before quite finishing the current one. I don't
remember that happening before.

Of course, that should be filed as a separate bug report.

comment:11 by aquadran, 15 years ago

i know about stoping voice too fast, imuse currently stoping
sounds imediately as should be(i'm not 100% sure), but maybe
it's not related. it of course depend of status of current
playing sound but maybe script want play voice too fast.

comment:12 by eriktorbjorn, 15 years ago

Resolution: fixed
Status: newclosed

comment:13 by eriktorbjorn, 15 years ago

Since the stuttering appears to be gone - or at the very
least much improved - and aquadran is aware of the new
problem, I'm closing this bug.

I may file a new bug report later. Not tonight, though.

Note: See TracTickets for help on using tickets.