Opened 16 years ago

Closed 16 years ago

#1152 closed defect (wontfix)

MI2: Overlapping music

Reported by: SF/johan_da_man Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

I noticed when playing MonkeyIsland2 that at first
apparently randomly music started playing over
eachother, the music from the area previously visited
playing over the music in the current area.

Then I tried to reproduce this and noticed that if you
leave one area, enter another area (and possibly then
enter a third area) quickly after eachother one tune MAY
be "stuck" in the background (actually I noticed this
when playing the game normally, when I was trying to
figure out what to do in the game and went quickly from
place to place this happened often, so I learned to not
go too quickly from place to place and avoided this
problem). This happened several times when I played
through the game with ScummVM 0.5.1 using english
MI2. I have encountered this problem mostly on Booty
island when entering or leaving the spitting contest and
other nearby locations, but also in other places.

Included is monkey2.s10 where this music jam has
already occured, and monkey2.s05 that can be used to
experiment to try to reproduce the problem.

Sometimes when I in savegame monkey2.s05 exit Wallys
room, exit Woodtick and enter Dread's ship (quickly after
eachother), two musics will overlap, sometimes they
don't. If they don't, try to go back to Scabb island and
leave woodtick that is automatically entered and return
to map and enter Dread's ship again, chanses are the
musics will overlap.

Sometimes rarely the problem goes away after going
through a few areas, but I'm not willing to chance that I
have to hear a dreadful mix of music for the rest of
game so I always load my previous save if it happens.

Another weird but quite harmless bug I noticed by
mistake is that if you pull the rope (!) found on Dinky
Island (after you pick it up), preferably in the same
screen or one near the pond where it was found,
another rope will be generated into the inventory and a
box identical to the one the rope was found on will be
blitted somewhere on the screen. If this is done outside
Dinky island the game will crash with a message "ERROR:
(91:1047:0x4C): findObjectInRoom: Object 1047 not
found in room 91", probably because the box is not
loaded in memory or something. Test it in save
monkey2.s07 (included).

Pull the rope many times to get as many ropes as you
want :) I didn't dare to continue in case it screwed
something up so I loaded my last savegame.

This bug is probably in the original game also, I would
think.

Also a third weird thing is that I don't seem to be able to
load saved games (at least in MI2 don't know about
other games) from the F5 menu, the load is grayed out,
so I can't load the autosave. Weird!

I probably should have made separate bug reports but
i'm way too lazy :)
All the saves are in monkey2weirdness.zip attachment.
Good luck fixing those! (hehe)

Ticket imported from: #788374. Ticket imported from: bugs/1152.

Attachments (1)

monkey2weirdness.zip (68.3 KB ) - added by SF/johan_da_man 16 years ago.
Three MonkeyIsland2 save files for debugging

Download all attachments as: .zip

Change History (4)

by SF/johan_da_man, 16 years ago

Attachment: monkey2weirdness.zip added

Three MonkeyIsland2 save files for debugging

comment:1 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: wontfix
Status: newclosed
Summary: Overlapping music and other minor bugsMI2: Overlapping music

comment:2 by fingolfin, 16 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (scummvm -v)
* Bug details, including instructions on reproducing it
* Language of game (English, German, etc)
* Version of game (Talkie, Floppy...)
* Platform and Compiler (Win32, Linux, MacOS, etc)
* Attach a save game if possible
* If this bug only occurred recently, please note the
last version without the bug, and the first version
including the bug. That way we can fix it quicker by
looking at the changes made.

This should only take you a little time but will make it much
easier for us to
process your bug report in a way that satisfies both you and
us.

Thank you for your support!

comment:3 by fingolfin, 16 years ago

"I probably should have made separate bug reports but i'm way
too lazy :) "

Ah come on, that's lame. You mean filing three bug reports is too
much effort for you? Well maybe in that case, we are way to lazy
to look at them, too? Why bother to report something if you don't
even read the notice text on the bug submission page? You don't
seem to have read it, otherwise you'd have followed the
instructions on it (like giving us details about your setup, filing
separate reports for each issue, etc.).

Note: See TracTickets for help on using tickets.