Opened 16 years ago

Closed 16 years ago

#1151 closed defect (wontfix)

MONKEYVGA: Game Uncompletable using Mac ScummVM 0.5.1

Reported by: SF/irq Owned by: SF/khalek
Priority: high Component: Engine: SCUMM
Keywords: script Cc:
Game: Monkey Island 1

Description

I ran into a bug that prevents the completion of the game
with Mac ScummVM 0.5.1, but not with the PC version.

The description of the bug contains some spoilers, so...

SPOILERS BEGIN HERE

Inside LeChuck's ghost ship, under Monkey Island, you
eventually make your way to a crate which has a root inside
that you need. After using the previously acquired Ghost
Tools on the chest, to open it, control is lost. Background
animations still occur, but you are unable to choose any
commands, and the mouse cursor does not move anymore.

In the PC version, right after you finish opening the crate
with the Ghost Tools, it plays a little sound effect that does
not end up happening on the Mac.

This is on a 12" Powerbook G4, 867MHz, 640MB ram, 60GB
HD, Mac OS X 10.2.6, ScummVM 0.5.6.

I have attached a save game. Simply "Use ghost tools with
glowing crate" and witness the breakage.

I was able to get by this by copying my save game to my
PC, performing that one step, saving, and then restoring on
the Mac. I haven't proceeded very far after that point yet but
haven't encountered any bugs otherwise.

Ticket imported from: #788278. Ticket imported from: bugs/1151.

Attachments (1)

monkeyvga.s04 (61.7 KB ) - added by SF/irq 16 years ago.
ScummVM save game

Download all attachments as: .zip

Change History (13)

by SF/irq, 16 years ago

Attachment: monkeyvga.s04 added

ScummVM save game

comment:1 by SF/irq, 16 years ago

Summary: Game Uncompletable using Mac ScummVM 0.5.1MONKEYVGA: Game Uncompletable using Mac ScummVM 0.5.1

comment:2 by SF/irq, 16 years ago

Priority: normalhigh

comment:3 by SF/irq, 16 years ago

Pretty much the same thing happens again, at the "Last Part"
screen... again, Mac only, not PC

comment:4 by SF/khalek, 16 years ago

so this is the floppy disk vga version of monkey island for PC's
or some other version? I assume its also an english version?

comment:5 by SF/irq, 16 years ago

Yes, it is the English floppy version.

comment:6 by SF/khalek, 16 years ago

this works fine here with latest cvs under x86 Linux

I don't suppose you have devtools installed and could
compile a cvs version?

comment:7 by SF/irq, 16 years ago

Yes, I should be able to build the cvs version, maybe sometime
this weekend.

comment:8 by SF/irq, 16 years ago

Um, I just realized what you said, khalek, that you're not using the
Mac version of ScummVM. My bug is specific to that. The problem
does not occur on any other version. Only the Mac version. This is
what my bug originally said.

comment:9 by SF/khalek, 16 years ago

you are using 0.5.1 this is not the latest code bugs should
be verified against a cvs build, please do so

comment:10 by SF/irq, 16 years ago

I downloaded the cvs version, built, and ran it. The bug is gone. It
gets right by it, no problem. HOWEVER - upon exiting the game,
all of my windows were messed up, in that they were in random
locations all over the screen, and random sizes. Not in the same
place/size they were before I started ScummVM. ScummVM 0.5.1
does not do this.

comment:11 by SF/khalek, 16 years ago

Owner: set to SF/khalek
Resolution: wontfix
Status: newclosed

comment:12 by SF/khalek, 16 years ago

Seeing as you can't reproduce this with latest CVS I'm
closing it.
The window messup thing I doubt is related to ScummVM and is
probably a libsdl thing (I think Fingolfin linked a CVS
version of SDL for 0.5.1). Anyway even if for some obscure
reason it is a ScummVM bug it should be in another bug report.

Note: See TracTickets for help on using tickets.