Opened 16 years ago

Closed 16 years ago

Last modified 10 months ago

#1150 closed defect (fixed)

CD/MP3/OGG: No music after loading savegame.

Reported by: SF/logicdeluxe Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

ScummVM 0.5.3cvs (Aug 13 2003 14:56:49)
This happens with all versions (EGA, VGA and enhanced
CD). The music does not play until a new music is played.
To reproduce this, just save and load in the opening
dialogue , in the SCUMM Bar or somewhere else while
music is playing.

Ticket imported from: #788195. Ticket imported from: bugs/1150.

Change History (11)

comment:1 Changed 16 years ago by Kirben

I can't reproduce this problem with new saved games in
monkeyega/vga, still occurs in monkey (CD) though.

comment:2 Changed 16 years ago by Kirben

This seems to be an mp3 (and maybe ogg too) issue, since it
occurs in zak256 too.

comment:3 Changed 16 years ago by fingolfin

To fix this, we'd have to add a way to save the status of the CD
"player", be it a real Audio CD or a MP3/Ogg track. Doing that for
MP3/Ogg actually wouldn't be that hard. But for the Audio CD, we'd
have to add a new method to OSystem.

comment:4 Changed 16 years ago by SF/cloney

This occurs in Indy3Towns, too. It's especially annoying as
the entirety of Castle Brunwald (where you have to do a lot
of loading and saving as you blunder into Nazis) has one CD
track as backing, so there's no way to get the music to
start again after loading a save game.

Surely you wouldn't need to save the position in the audio
track, just which track is playing at the time?

comment:5 Changed 16 years ago by Kirben

Summary: MI1: no music after loading savegame.CD/MP3/OGG: No music after loading savegame.

comment:6 Changed 16 years ago by fingolfin

The problem is the loop status. I can do what you suggest as long
as I may assume that CD tracks are always either played exactly
once, or looped infinity many times.

comment:7 Changed 16 years ago by fingolfin

Owner: set to fingolfin

comment:8 Changed 16 years ago by fingolfin

Some code for this is in CVS. It won't help for old savegames, but
it does store the information about the currently playing CD track
when you make a new savegame.

Upon load, it will resume playing, *if* the CD track was set to
loop forever. I could also make it restart the track if it was set to
loop a finite number of times (e.g. 1 time), but there are both
arguments for and against this...

Please test if this helps.

comment:9 Changed 16 years ago by fingolfin

Resolution: fixed
Status: newclosed

comment:10 Changed 16 years ago by fingolfin

It works for me. Since nobody complained, I'll close this now.

comment:11 Changed 10 months ago by digitall

Component: Engine: SCUMM
Game: Monkey Island 1
Note: See TracTickets for help on using tickets.