Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1149 closed defect (fixed)

SAM: Crash when using retriever on Max

Reported by: SF/dfabulich Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

In the attached save, use the broken golf ball
retriever + severed hand + magnet object on Max in the
tank. The game will crash with the following output on
the console:

"Assertion failed: idx >= 0, file scumm/object.cpp,
line 227"

Note that this is not required to complete the game,
but shouldn't crash the game regardless!

I'm using Win2K English version, ScummVM 0.5.1 (Aug 7
2003 00:29:29).

Ticket imported from: #787841. Ticket imported from: bugs/1149.

Attachments (1)

samnmax.s01 (86.1 KB ) - added by SF/dfabulich 16 years ago.
Saved game in front of Max w/ retriever

Download all attachments as: .zip

Change History (5)

by SF/dfabulich, 16 years ago

Attachment: samnmax.s01 added

Saved game in front of Max w/ retriever

comment:1 by eriktorbjorn, 16 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:2 by eriktorbjorn, 16 years ago

Should be fixed in latest CVS. I actually heard of this bug
once before, but I thought it meant using an object on Max
*after* you had crossed the water, so I couldn't reproduce
it then.

comment:3 by SF/marpa, 16 years ago

When the bucket of golfballs is used on max (right after
he's thrown in the tank) the game crashes. This on linux and
win2k. Win32 daily snapshot binary version and latest stable.

scummvm: scumm/object.cpp:227: void
Scumm::getObjectXYPos(int, int&, int&, int&): Assertion `idx
>= 0' failed.

comment:4 by eriktorbjorn, 16 years ago

I can't reproduce this. Not with the snapshot at least.

Note: See TracTickets for help on using tickets.