Opened 16 years ago

Closed 15 years ago

#1000 closed defect (fixed)

FOA/MI2 (Amiga) Palette issues

Reported by: SF/logicdeluxe Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

ScummVM 0.5.0pre-cvs
Built on Jul 13 2003 02:36:02
I noticed that the original Amiga executable simply
does not fade in most cases. The fading LucasArts, the
Monkey Island logo and the red fade before the dream at
the big tree are rare instances where the Amiga version
actually DOES a color fade. E.g. the teaser where
Guybrush tells his story to the governor does not fade.
Also when digging out the bone on Scab, there is no
darkening and flashing effect at all. Usually it would
be no problem when ScummVM DOES fade those scenes, even
the original didn't, but a problem occours in the
voodoo hut on Scab. While standing on the left side,
all is displayed bright as usual, but when going to the
voodoo lady the entire screen fades very dark (the way
the PC version does with the left part of the room), so
you barely can see a thing including the dialogue line
selection.
There would be probably more problems of that kind in
MI2 and also FOA.
The same goes for actors (even I did not notice fading
problems there yet), e.g. in the bar on Scab you are
fully bright even in the darkest corner of that low
lighten room with the original Amiga executable.
Obviously there are some screen effects left out in the
Amiga conversion, but they are still in use in the
scrips. This also might be the reason for those many
gliches in the title sequence since there are a lot of
fades used. You could disable color fades for
background graphics experimentally for Amiga games and
test if it would play better then.

Ticket imported from: #770268. Ticket imported from: bugs/1000.

Change History (10)

comment:1 by fingolfin, 16 years ago

Summary: MI2 Amiga color fadesMI2: Amiga color fades

comment:2 by Kirben, 16 years ago

The black out problem in intro. and Voodoo Ladies place is
caused by case 8 of o5_roomOps in scumm/script_v5.cpp but
disabling it causes text to be invible (black).
The Amiga version is sending high value in value d in case
4 'set palette color' of the same function.
A quick comparsion of first room:
Amiga:
WARNING: set pal. color a is 83 b is 0 c is 83 d is 69!
WARNING: set pal. color a is 223 b is 83 c is 223 d is 70!
WARNING: set pal. color a is 23 b is 0 c is 23 d is 49!
WARNING: set pal. color a is 127 b is 47 c is 127 d is 68!

comment:3 by Kirben, 16 years ago

PC:
WARNING: set pal. color a is 83 b is 0 c is 83 d is 2!
WARNING: set pal. color a is 223 b is 83 c is 223 d is 3!
WARNING: set pal. color a is 23 b is 0 c is 23 d is 1!
WARNING: set pal. color a is 127 b is 47 c is 127 d is 6!

comment:4 by Kirben, 16 years ago

Summary: MI2: Amiga color fadesFOA/MI2: Amiga color fades

comment:5 by Kirben, 16 years ago

According to ScummRev the Amiga versions of FOA & MI2 had
an EPAL resource, which was the 'EGA Palette'. I think it
might help with these color issues.

comment:6 by Kirben, 16 years ago

Summary: FOA/MI2: Amiga color fadesFOA/MI2 (Amiga) Palette issues

comment:7 by fingolfin, 16 years ago

I am not sure what exactly you mean, Kirben... how exactly do
you think the EPAL resource would help?!

comment:8 by Kirben, 16 years ago

I just thought it might have been possible to use the EGA
palettes from EPAL resource, to avoid problems. But that
would reduce the games to 16 colots only, so not worth it.

comment:9 by Kirben, 15 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:10 by Kirben, 15 years ago

The problem was due to Amiga verisons of FOA/MI2 using a
unique VAR_VIDEOMODE value of 82 in order to set palette
differences. Fixed in ScummVM cvs.

Note: See TracTickets for help on using tickets.