Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#1001 closed defect (fixed)

MM: walking through air

Reported by: SF/logicdeluxe Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

ScummVM 0.5.0pre-cvs
Built on Jul 13 2003 02:36:02
Sometimes kids walk the direct line ignoring walkboxes.
It usually happens at stairs. I could not reproduce
such a certain condition. It seems it happens randomly.
It happens 2 times at the stair outside the arcade
room, last time I played through the game completely.
When I played the game before, it happens on other
places as well.

Ticket imported from: #770306. Ticket imported from: bugs/1001.

Change History (6)

comment:1 Changed 16 years ago by SF/hibernatus

Same as #769897 (which is closed anyway).
I saw that bug in indy3 (a while ago), zak v2 (latest cvs), mm
v2 (recently).

comment:2 Changed 16 years ago by SF/segra

Just witnessed the same bug twice on the stairs, interestly
enough while i was playing with a bug i just reported, when i
loaded a save game Syd walked straight through the stairs.
Then when I reloaded the game, he followed the stairs
around rather than just walk over the top of the rail.
I couldnt get it to repeat again... very odd

comment:3 Changed 16 years ago by SF/segra

After restarting scummvm and loading the savegame, the bug
does occur. I've uploaded the savegame to

http://home.iprimus.com.au/strobs/maniac.s00

that was saved using the latest cvs, v2 maniac eng.
Scummvm must be restarted for the bug to reoccur, just load
the game and Syd will walk through the stairs.

comment:4 Changed 16 years ago by fingolfin

Sounds a lot like a memory-not-inited issue. Might be useful to
run valgrind over this.

comment:5 Changed 16 years ago by fingolfin

Turns out that walkdata was not being inited. Furthermore,
walkdate.point3x isn't saved.

comment:6 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.