Opened 2 years ago

Closed 2 years ago

#9943 closed defect (fixed)

MOHAWK: Riven: 'confirm_exit' option displays dialog when game ends.

Reported by: macca8 Owned by: bgK
Priority: normal Component: Engine: Mohawk
Keywords: Cc:
Game: Riven

Description

This is an unusual bug in that the feature it refers to isn't standard for Riven.

With the recent overhaul of the Riven engine, the 'confirm_exit' option now intercepts the automatic quit generated when the game ends (didn't previously), displaying an unnecessary dialog to the player.

For the record, clicking Quit closes both Riven and ScummVM as expected, however clicking Cancel relaunches the end game.

Having said that, the pertinent issue here is that the dialog shouldn't appear.

To reproduce:

  • manually add the line 'confirm_exit=true' to the ScummVM section of the Config File.
  • using the attached saved game, press the button beside the telescope to launch the end game.

Note that any end game can be used for this test.

I've added this option to the Config File because Riven doesn't currently offer a 'Prompt to Save' feature (unlike the original, which does). It provides the first part of the required functionality (the second part is to return to the in-game menu to complete the save) by intercepting player exit calls (Quit, Return to Launcher, but NOT Load) for a game in progress, and continues to do so.

Hopefully a proper 'Prompt to Save' feature can be added in the near future.

Current Daily Build: 1.10.0git3775-geb73062 (11 July 2017)
Last known without bug: 1.10.0git3512-gdeab63f (21 June 2017)
Game Version: English, 5-CD (contains v1.02 patch files)
Platform: Intel Mac (OS X 10.6.8)

Attachments (1)

riven-014.rvn (25.0 KB ) - added by macca8 2 years ago.
Telescope end game test

Download all attachments as: .zip

Change History (3)

by macca8, 2 years ago

Attachment: riven-014.rvn added

Telescope end game test

comment:1 by macca8, 2 years ago

Please ignore my comment above about the behaviour of the Cancel button. Turns out this was corrected by one of the changes over the last few days. All it does in this case is close the dialog.

comment:2 by bgK, 2 years ago

Owner: set to bgK
Resolution: fixed
Status: newclosed

Thanks for your report. This is now fixed (Commit 69c1f70).

Note: See TracTickets for help on using tickets.