Opened 5 years ago

Closed 11 months ago

#9944 closed defect (wontfix)

SCI: KQ5: Crispin Area Pathfinding Loop

Reported by: dafioram Owned by: sluicebox
Priority: low Component: Engine: SCI
Version: Keywords: pathfinding
Cc: Game: King's Quest 5

Description

ScummVM: 1.10.0git-3766-gb0ecbc9 64bit
Game: Kings Quest 5 Windows/English 1.000.052
OS: Win7-64

When transversing the screen with Crispin's house if you click in a bad spot, somewhere near the hill or lower, then Graham will loop back and forth over the hill. I was coming from the top left and heading down over the bridge.

I cannot reproduce this so if this gives insight into where to patch in the code great, but if not I wouldn't bother.

I was able to click away when it showed the walking icon so I could get out of the loop.

Demo: https://streamable.com/x62dg

Attachments (1)

kq5-cd-win.049 (42.2 KB ) - added by dafioram 5 years ago.
Persistence pays off. Attached is the saved game in the infinite loop.

Download all attachments as: .zip

Change History (6)

comment:1 by m-kiewitz, 5 years ago

Does this also happen in the original interpreter?

comment:2 by dafioram, 5 years ago

Even if it does I doubt anyone can reproduce it since I can't even reproduce it in scummvm. Because it was looping I was able to start my video recording software to capture it.

by dafioram, 5 years ago

Attachment: kq5-cd-win.049 added

Persistence pays off. Attached is the saved game in the infinite loop.

comment:3 by csnover, 5 years ago

Keywords: sci removed

comment:4 by dafioram, 5 years ago

Keywords: pathfinding added
Summary: SCI: KQ5: Crispin Area Pathing LoopSCI: KQ5: Crispin Area Pathfinding Loop

comment:5 by sluicebox, 11 months ago

Owner: set to sluicebox
Resolution: wontfix
Status: newclosed

I reproduced this once in ScummVM (it took a while) and it's funny but it doesn't break anything since you can just click to stop it. We also haven't established if it's original behavior or a consequence of our pathfinding algo (which may eventually be a moot issue...)

Either way, I don't think it meets the threshold for intervention and it's pretty rare and it doesn't have any negative consequences. (And it's been four years!)

Note: See TracTickets for help on using tickets.