Opened 16 years ago

Closed 16 years ago

#982 closed defect (fixed)

0.5.0 RC: MM(V2) Inventory doesn't work under certain circum

Reported by: SF/wishbone Owned by: SF/ender
Priority: blocker Component: Engine: SCUMM
Keywords: script Cc:
Game: Maniac Mansion

Description

Sometimes, when switching kids, the inventory doesn't
work. It looks empty, but with an arrow pointing
upwards, as if there's something higher up. The arrow
doesn't do anything, though. One way I've found of
fixing it, is to switch to another kid, move his inventory
all the way to the top, and switch back again.

Additional: After experimenting with this, I think I can
conclude that this only happens when the person you're
switching from (or the last person to have a working
inventory) has his inventory at a lower position than
exists in the inventory of the person you're switching to.
To paraphrase: if Syd's inventory is at items 7-10, and
you switch to Bernard who has only 2 items at this time,
this bug occurs. The solution: Switch back to Syd, move
his inventory to the top, and switch back again.

Note to developer: I think the cause of this must be
that the position of the inventory is stored in a single
variable, rather than in a separate one for each
character.

Ticket imported from: #769896. Ticket imported from: bugs/982.

Change History (5)

comment:1 Changed 16 years ago by SF/wishbone

My setup:
Scummvm0.5.0-pre, daily win32 snapshot, 11 Jul 2003
Win98

comment:2 Changed 16 years ago by SF/ender

I'll take this one.

comment:3 Changed 16 years ago by SF/ender

Owner: set to SF/ender
Priority: normalblocker
Summary: MM(V2) Inventory doesn't work under certain circumstances0.5.0 RC: MM(V2) Inventory doesn't work under certain circum

comment:4 Changed 16 years ago by SF/ender

Resolution: fixed
Status: newclosed

comment:5 Changed 16 years ago by SF/ender

Fixed, the inventory posision is now reset every time the
active player is modified.

Note: See TracTickets for help on using tickets.