Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#929 closed defect (fixed)

MI1: hangs at part one screen

Reported by: SF/logicdeluxe Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

ScummVM 0.4.2cvs
Built on Jun 28 2003 11:13:46
Windows. PC CD-ROM. All languages.
After the intro sequence, the screen "Part One" appears
and the game hangs and does not continue until I press
ESC to advance to the next scene. (I did wait some minutes)
This does not happen in the VGA disk version.

Ticket imported from: #762886. Ticket imported from: bugs/929.

Change History (12)

comment:1 by eriktorbjorn, 16 years ago

Are you playing the music from CD, from MP3 or from Ogg
Vorbis? Ogg Vorbis works fine for me with the Windows
snapshot I just downloaded. I can't test the other two right
now since my Monkey Island CD is at home and I'm not.

comment:2 by SF/logicdeluxe, 16 years ago

I played with MP3 96kbps, 22kHz.
I just checked with CD-Audio, too. With CD-Audio it works
fine. Seems to be an MP3 specific bug.

comment:3 by SF/logicdeluxe, 16 years ago

Component: Engine: SCUMM
Game: Monkey Island 1

comment:4 by fingolfin, 16 years ago

Maybe this was broken during my recent mixer code changes
(there was a vorbis regression back then, too, which I fixed
immediately, though). Since I don't have MonkeyCD, I can't
really do much about this, though.

comment:5 by eriktorbjorn, 16 years ago

I can't reproduce this even in the MP3 case. At least not
under Linux.

The only problem I noticed was that at the very end of the
track, just before leaving the part one screen, there was a
brief noise from earlier in the track. (At first I thought
it was looping the music.) But I think I know how to fix that.

comment:6 by Kirben, 16 years ago

Still occus with latest ScummVM cvs under Windows and I get
seven of these errors after the part one music finishes:
Error decoding after restream 1

comment:7 by fingolfin, 16 years ago

Are your MP3 file(s) fine (i.e. not maybe damaged)? Does it work
fine with those file when you use 0.4.1

comment:8 by Kirben, 16 years ago

The problem doesn't occur under ScummVM 0.4.1, so the mp3
files seem fine.

comment:9 by SF/logicdeluxe, 16 years ago

ScummVM 0.4.2cvs
Built on Jul 5 2003 00:28:03
I checked it with Vorbis as well: The same issue as with
MP3. So it is not only MP3 but Vorbis as well. And it works
fine with 0.4.1 for me, too.

comment:10 by eriktorbjorn, 16 years ago

I still can't reproduce this. Is anyone who can looking into it?

comment:11 by Kirben, 16 years ago

Problem has been fixed in ScummVM cvs.

I will add a new bug report for that error message, since that
is different issue.

comment:12 by Kirben, 16 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.