Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#880 closed defect (worksforme)

MI1VGA: Game crashes entering the church

Reported by: SF/mondongo Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

Version: ScummVM 0.4.1
Description: When I am outside the church on the town
and I click on the door to enter, the game crashes.
Language: English
Version: monkey1vga
Platform: Debian testing/unstable (I updated to the
latest scummvm, libsdl and libc hoping to fix it; the rest
of the libraries are from testing).

I attach a savegame. I have also a backtrace from gdb:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16384 (LWP 19776)]
0x0806c44e in strcpy ()
(gdb) bt
#0 0x0806c44e in strcpy ()
#1 0x0000000a in ?? ()
#2 0x0806bd0b in strcpy ()
#3 0x08078a3a in strcpy ()
#4 0x080786cd in strcpy ()
#5 0x0807876b in strcpy ()
#6 0x0806b4e0 in strcpy ()
#7 0x080513b4 in strcpy ()
#8 0x080537ab in strcpy ()
#9 0x08053984 in strcpy ()
#10 0x080ad4d9 in putchar ()
#11 0x40288a51 in __libc_start_main () from
/lib/libc.so.6

Ticket imported from: #753039. Ticket imported from: bugs/880.

Attachments (3)

monkeyvga.s20 (42.0 KB) - added by SF/mondongo 16 years ago.
savegame.gz (7.7 KB) - added by SF/mondongo 16 years ago.
Savegame, just outside the church
savegame.2.gz (7.7 KB) - added by SF/mondongo 16 years ago.

Download all attachments as: .zip

Change History (14)

Changed 16 years ago by SF/mondongo

Attachment: monkeyvga.s20 added

Changed 16 years ago by SF/mondongo

Attachment: savegame.gz added

Savegame, just outside the church

Changed 16 years ago by SF/mondongo

Attachment: savegame.2.gz added

comment:1 Changed 16 years ago by SF/mondongo

Summary: Game crashes entering the churchGame crashes entering the church...

comment:2 Changed 16 years ago by SF/jamieson630

Summary: Game crashes entering the church...MI1VGA: Game crashes entering the church

comment:3 Changed 16 years ago by fingolfin

Can you still reproduce the problem with latest CVS?

Can't use that english save game in my german monkeyvga.
However, if I walk to the church in a new game, I can enter it
just fine w/o a crash.

comment:4 Changed 16 years ago by fingolfin

Can you still reproduce the problem with latest CVS?

Can't use that english save game in my german monkeyvga.
However, if I walk to the church in a new game, I can enter it
just fine w/o a crash.

comment:5 Changed 16 years ago by SF/mankeli

With savegame it crashes on Win2003 / latest daily build
(June 22, 2003, 8:11 am)
However it works just fine if you don't use that savegame.

Could this happen because of script desync?

comment:6 Changed 16 years ago by fingolfin

Joaquin, please tell us if you also get a crash if you play to the
church from the start (instead of using a save game).

comment:7 Changed 16 years ago by fingolfin

Status: newpending

comment:8 Changed 16 years ago by SF/mondongo

I just tried and in a new game I can enter the church just
right. :S

comment:9 Changed 16 years ago by SF/mondongo

Status: pendingnew

comment:10 Changed 16 years ago by fingolfin

Well then I guess it's just the savegame being corrupt. Sorry
nothing we can do about that.

comment:11 Changed 16 years ago by fingolfin

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.