Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#853 closed defect (fixed)

0.5.0 RC: ZAK: no return from cutscene in TPC shop

Reported by: SF/ge0rg Owned by: SF/hoenicke
Priority: blocker Component: Engine: SCUMM
Keywords: script Cc:
Game: Zak McKracken

Description

When you call the TPC shop and later hang up, or when
you break through the floor to the secret room, the
dumb alien guy from the TPC shop is shown as he hangs
up / looks for the secret room, and the focus never
returns to Zak - it is not possible to Esc this sequence.

I've used the enhanced (v2) german zak version and
current CVS:

ScummVM 0.4.2cvs
Built on Jun 7 2003 13:01:46

a save game is appended (either hang up the phone or
use the rope to reproduce)

Ticket imported from: #750626. Ticket imported from: bugs/853.

Attachments (1)

zak.s02 (51.2 KB ) - added by SF/ge0rg 16 years ago.
zakega savegame

Download all attachments as: .zip

Change History (8)

by SF/ge0rg, 16 years ago

Attachment: zak.s02 added

zakega savegame

comment:1 by fingolfin, 16 years ago

Summary: no return from intermediate sequence in TPC shopZAK: no return from cutscene in TPC shop

comment:2 by SF/ender, 16 years ago

Priority: normalblocker
Summary: ZAK: no return from cutscene in TPC shop0.5.0 RC: ZAK: no return from cutscene in TPC shop

comment:3 by fingolfin, 16 years ago

The problem is caused by script-77 never reaching the
endCutscene statement, instead it hangs forever in the loop just
before that:

[00B6] (19) doSentence(253,157,0,1)
[00BD] (80) breakHere()
[00BE] (A8) unless (Var[48]) goto 00BD;
[00C2] (9A) VAR_EGO = Var[117];
[00C5] (C0) endCutscene
[00C6] (A0) stopObjectCode()

So, it waits for Var48 to be set, which doesn't happen. Looking at
roomobj-4-157 (which runs because of doSentence(253,157,0,1)),
there is a Var[48]++; in it; but AFAICT, that script itself hangs on
a waitForSentence statement.

comment:4 by SF/hoenicke, 16 years ago

This is fixed now. I don't have permissions to close this bug, though.

comment:5 by SF/ender, 16 years ago

Great, hoenicke :)

One thing tho, when you commit to CVS please note what bug
the change fixes in the commit message. Also I have just
given you access to close/edit/etc bugs, sorry about that.

comment:6 by SF/ender, 16 years ago

Owner: set to SF/hoenicke
Resolution: fixed
Status: newclosed

comment:7 by SF/ender, 16 years ago

Great, hoenicke :)

One thing tho, when you commit to CVS please note what bug
the change fixes in the commit message. Also I have just
given you access to close/edit/etc bugs, sorry about that.

Note: See TracTickets for help on using tickets.