Opened 16 years ago

Closed 16 years ago

#848 closed defect (fixed)

INDY3EGA: music causes intro to hang

Reported by: SF/khalek Owned by: SF/hoenicke
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

with the recent enabling of music for indy3ega it would
seem that the game logo and rest of the intro doesn't
come up anymore. You can still get to the game via
pressing escape but its clearly a bug.

I guess its calling something like isSoundRunning or
some such, haven't looked at the scripts in question

Running scummvm with the -a flag for indy3ega (which
currently disables music) results in the intro being
run normally.

latest cvs,
english version

Ticket imported from: #749898. Ticket imported from: bugs/848.

Change History (6)

comment:1 by fingolfin, 16 years ago

The problem is not isSoundRunning. I thought I had explained to
you on IRC what the problem was, khalek? It's
Player_V2::getMusicTimer not returning the appropriate value.
Commenting out or removing the following lines from
scummvm.cpp hence works around the problem:
} else if (_playerV2) {
VAR(VAR_MUSIC_TIMER) = _playerV2->getMusicTimer();

comment:2 by fingolfin, 16 years ago

The problem is not isSoundRunning. I thought I had explained to
you on IRC what the problem was, khalek? It's
Player_V2::getMusicTimer not returning the appropriate value.
Commenting out or removing the following lines from
scummvm.cpp hence works around the problem:
} else if (_playerV2) {
VAR(VAR_MUSIC_TIMER) = _playerV2->getMusicTimer();

comment:3 by SF/khalek, 16 years ago

if you did explain to me on irc I must have forgotten, no
need to repeat yourself though :)

comment:4 by SF/hoenicke, 16 years ago

It seems the music_timer is handled differently in V3 games. I have
added a fix for this. I tested it with indyvga (and a hacked version of
scummvm that uses PCjr for SMALL_HEADER games).

I'm not sure if the timing is 100% correct. I can't run the dos version
here.

comment:5 by SF/hoenicke, 16 years ago

Resolution: fixed

comment:6 by SF/hoenicke, 16 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.