Opened 16 years ago

Closed 16 years ago

#816 closed defect (fixed)

COMI: Too many scripts running, 40 max

Reported by: SF/inguin Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Monkey Island 3

Description

Reopening bug #739463, because it's easily reproducable, even with
today's CVS version:
-Play until the beginning of Part II (savegame for the german version
attached)
-Leave and enter the fort for a couple of times (seven times, at least
on my system)
-ScummVM opens the console, reporting "ERROR (14:19:0x59): Too
many scripts running, 40 max".

Ticket imported from: #743672. Ticket imported from: bugs/816.

Attachments (1)

comi.s01 (213.5 KB ) - added by SF/inguin 16 years ago.
Savegame, beginning of part II

Download all attachments as: .zip

Change History (8)

by SF/inguin, 16 years ago

Attachment: comi.s01 added

Savegame, beginning of part II

comment:1 by fingolfin, 16 years ago

Just to clarify something here, bug #739463 never was closed, it was
only set to "pending" because I was waiting for an answer. And you
didn't reopen it either, you filed a new bug report.

comment:2 by fingolfin, 16 years ago

I don't have my COMI handy right now, but least this sounds like finally
a good way to reproduce the problem (re-entering the fort 7 times,
that sounds like we don't quite a script properly, or something like
that).

comment:3 by fingolfin, 16 years ago

Owner: set to fingolfin

comment:4 by fingolfin, 16 years ago

Your save game unfortunately doesn't load for me - or rather, it does
load, but then is frozen.

Stsill, I can reproduce the problem with a save game of my own. What
happens is that script 88 is run up to 15 times in parallel, and script
112 8 times; and various other scripts run, too. So maybe we just have
to increase the maximum count of allowed parallel script from 40 to,
say, 60. BUT I am not 100% sure on this - because script 88, while
apparently having a max. of 15 instances, seems to be run *16* times.
If it wasn't for that, 40 script slots might suffice. Investigating...

comment:5 by fingolfin, 16 years ago

To elaborate a bit on what I said: script 88 is for the chickens. Indeed one
script runs up to 15 of them, but there is one additional added by another
script, so that's fine.
In my tests, only intermediately are more than 40 scripts running (41 or 42).
So it's still quite possible that we are doing something wrong, either in the
way we execute the scripts (the order etc.) or in some of the startScript
opcodes.

Still, the easiest fix will be to increase the max script count to say 80. I'll do
that in the next save game revision.

comment:6 by fingolfin, 16 years ago

Resolution: fixed
Status: newclosed

comment:7 by fingolfin, 16 years ago

Fixed by increasing the max. script count to 80.

Note: See TracTickets for help on using tickets.