Opened 18 years ago

Closed 18 years ago

Last modified 2 years ago

#8010 closed patch (fixed)

Loom graphics fix

Reported by: eriktorbjorn Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

There is a bug can cause actors in GF_SMALL_HEADER games to be drawn in front of objects, when they should be obscured by them. This semms to be because CostumeRenderer::mainRoutine() assumes that 'masking' will be either 1 or 0. However, in the GF_SMALL_HEADER it's set to _zbuf, which may be greater than that.

This can be seen in Loom, in the forest where you encounter the shepherds, and in the house where you meet with Fleece. Could someone please check that I haven't inadvertently broken any other GF_SMALL_HEADER games?

The patch is made against an August 13 CVS snapshot.

Ticket imported from: #594922. Ticket imported from: patches/115.

Attachments (5)

masking.diff (457 bytes ) - added by eriktorbjorn 18 years ago.
Loom graphics fix
loomcd.s01 (42.4 KB ) - added by eriktorbjorn 18 years ago.
Saved game, forest
loomcd.s02 (42.2 KB ) - added by eriktorbjorn 18 years ago.
Saved game, Fleece's house
fleece1.png (23.4 KB ) - added by eriktorbjorn 18 years ago.
Fleece outside the window
fleece2.png (23.3 KB ) - added by eriktorbjorn 18 years ago.
Fleece outside the window, patched version

Download all attachments as: .zip

Change History (13)

by eriktorbjorn, 18 years ago

Attachment: masking.diff added

Loom graphics fix

by eriktorbjorn, 18 years ago

Attachment: loomcd.s01 added

Saved game, forest

by eriktorbjorn, 18 years ago

Attachment: loomcd.s02 added

Saved game, Fleece's house

by eriktorbjorn, 18 years ago

Attachment: fleece1.png added

Fleece outside the window

by eriktorbjorn, 18 years ago

Attachment: fleece2.png added

Fleece outside the window, patched version

comment:1 by SF/ender, 18 years ago

Looked great, and fairly obvious. Thanks :)

comment:2 by SF/ender, 18 years ago

Owner: set to SF/ender
Resolution: fixed
Status: newclosed

comment:3 by fingolfin, 18 years ago

This also fixes the store way railing in MonkeyVGA

comment:4 by fingolfin, 18 years ago

Status: closednew

comment:5 by fingolfin, 18 years ago

However, now the guy in the TPC shop is in front of the counter.

comment:6 by fingolfin, 18 years ago

Status: newclosed

comment:7 by fingolfin, 18 years ago

nm, ignore me - this was not caused by this fix but rather by some box tweaks I am making right now (0x40 vs 0x80...). Sorry, should have checked that first.

comment:8 by digitall, 2 years ago

Component: Engine: SCUMM
Game: Loom
Note: See TracTickets for help on using tickets.