Opened 16 years ago

Closed 16 years ago

#798 closed defect (fixed)

ZAK256 copy protection?

Reported by: SF/logicdeluxe Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Zak McKracken

Description

ScummVM 0.4.1cvs
Built on May 23 2003 16:51:18
When I try to go to the phone company store or to the
14th Avenue, Zak turns back and says: "This is a
limited game, since the Copy Protection failed"
I have all files and mp3 tracks on my harddisk. It
worked fine in previous versions of ScummVM.

Ticket imported from: #742245. Ticket imported from: bugs/798.

Change History (6)

comment:1 by fingolfin, 16 years ago

Is this with a newly started game, or using a savegame?

I can't reproduce this in either case.

comment:2 by Kirben, 16 years ago

I can confirm the problem, when trying to enter 14th Avenue
with current ScummVM, but the problem doesn't occur in
ScummVM 0.4.0

comment:3 by SF/logicdeluxe, 16 years ago

I started a new game. My old savegames do not work any more,
so I've deleted them.

comment:4 by SF/andrej4000, 16 years ago

I found at least, how to work-around this bug. see attached
object-codes-decompiles.

//START OC OF THE DOOR
Events:
2 - 0022
3 - 0038
7 - 002D
[0022] (0A) startScript(31,[135])
[0028] (07) setState(151,1)
[002C] (00) stopObjectCode()
[002D] (0A) startScript(32,[135])
[0033] (07) setState(151,0)
[0037] (00) stopObjectCode()
[0038] (A8) if (Var[151 Bit 8]) {
[003D] (91) animateCostume(Var[1],250)
[0041] (D8) printEgo([Text("This is a limited game, since the
Copy Protection failed")]);
[007C] (2E) delay(60)
[0082] (18) } else {
[0080] (0F) if (getState(135) == 1) {
[0089] (24) loadRoomWithEgo(151,4,-1,-1)
[0091] (**) }
[0091] (**) }
[0091] (00) stopObjectCode()
END
//END OC OF THE DOOR

//START OC OF THE 14TH AVENUE
Events:
FF - 0023
[0023] (A8) if (Var[151 Bit 8]) {
[0028] (91) animateCostume(Var[1],250)
[002C] (D8) printEgo([Text("This is a limited game, since
the Copy Protection failed")]);
[0067] (2E) delay(60)
[006D] (18) } else {
[006B] (24) loadRoomWithEgo(160,5,40,116)
[0076] (**) }
[0076] (00) stopObjectCode()
END
// END OC OF THE 14TH AVNUE

in both cases Var[151 Bit 8] is checked.

comment:5 by SF/andrej4000, 16 years ago

Bug-report can be closed, fingolfin fixed it in the CVS an I
tested it. Works fine! :D

comment:6 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.