Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#790 closed defect (fixed)

COMI: can't examine things in inventory

Reported by: SF/barneyntd Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I'm using:
ScummVM 0.4.1cvs
Built on May 19 2003 17:41:22

to run Curse of Monkey Island (CD bought recently in UK)
under MacOS X.

I have picked up various objects through the game which I'm sure I
should be able to look at (for example, the treasure map to where
Elaine is buried in Part II) but when I try to examine them, nothing
appears.

I have attached a save game where I have just picked up a recipe book
in part IV, but I can't see the recipes!

Barney.

Ticket imported from: #740148. Ticket imported from: bugs/790.

Attachments (1)

comi.s17 (247.1 KB) - added by SF/barneyntd 16 years ago.
savegame with recipe book in inventory

Download all attachments as: .zip

Change History (12)

Changed 16 years ago by SF/barneyntd

Attachment: comi.s17 added

savegame with recipe book in inventory

comment:1 Changed 16 years ago by SF/barneyntd

Component: Engine: SCUMM
Game: Monkey Island 3

comment:2 Changed 16 years ago by SF/jamieson630

I can confirm this problem too. I had to back up to a previous
savegame so I could write down the treasure map when I first
obtained it, because it was impossible to look at it again. And
I did the recipe thing from memory, since I was never able to
look at the book. This problem also comes up with looking at
the picture of El Pollo Diablo in the restaurant. The first time,
it will come up. After that, it will not.

As for the savegame, my latest CVS copy is crashing when
trying to load it. olki and khalek mentioned the same problem
on IRC.

comment:3 Changed 16 years ago by SF/jamieson630

BTW, this happens when you try to look at things that go full-
screen (the treasure map, the recipe book, the picture on the
restaurant wall, etc.).

comment:4 Changed 16 years ago by eriktorbjorn

Hmm... Don't ask me why, but at least for the recipe book it
seems to be related to the VAR_GAME_LOADED variable. I think
it's script-8 that's responsible for showing (and hiding?)
the book, and it simply does

[0000] (83) freezeUnfreeze(2)
[0006] (AB) saveGame()
[0008] (67) breakHere()
[0009] (65) if (VAR_GAME_LOADED) {
[0013] (6D) var214 = 1
[001D] (83) freezeUnfreeze(0)
[0023] (7C) stopScript(0)
[002D] (66) } else {
[0029] (6D) var214 = 0
[0038] (9D) loadRoom(localvar0)
[003E] (**) }
[003E] (7B) stopObjectCode()
END

In scummLoop(), if I remove the condition "!(_features &&
GF_AFTER_V8)" (which is clearly wrong anyway, since at the
very least it should be &, not &&) I can read the recipe
book as many times as I like, but I don't know if it breaks
anything else.

comment:5 Changed 16 years ago by eriktorbjorn

By the way, I had problems loading the savegame so I used
the debugger to jump to room 61 instead.

comment:6 Changed 16 years ago by eriktorbjorn

After some discussion with Fingolfin, I've made the change
so that VAR_GAME_LOADED is always reset, if it's available.

Does this fix the other cases? I only checked with the
recipe book.

comment:7 Changed 16 years ago by fingolfin

Owner: set to eriktorbjorn
Resolution: fixed
Status: newpending

comment:8 Changed 16 years ago by SF/jamieson630

Status: pendingnew

comment:9 Changed 16 years ago by SF/jamieson630

In the latest CVS, the portait of El Pollo Diablo can now be
viewed multiple times, both with a new game and with a
savegame that existed before the fix. Thanks, eriktorbjorn!
Can't get enough of that portrait....

comment:10 Changed 16 years ago by eriktorbjorn

Status: newclosed

comment:11 Changed 16 years ago by eriktorbjorn

Note: See TracTickets for help on using tickets.