Opened 10 years ago

Closed 10 years ago

Last modified 12 months ago

#7727 closed enhancement (duplicate)

WinCE/PocketPC screen alignment on WVGA devices with scalers

Reported by: SF/pncfreak Owned by: sev-
Priority: normal Component: Port: WinCE
Keywords: Cc:
Game:

Description

Request for ARM optimized x2 scaler (and non-aspect correct full-screen scaler), as well as removal of click point/mouse cursor off-set discrepancy.

Result from first test of ARM optimized AdvMAMEx2 scaler:

Test phone:

HTC Touch Pro2

Specs:

CPU: Qualcomm(R) 7200A

Speed: 528 MHz

RAM: 258 MB

Flash: 512 MB

Databus: 32 bit

Screen size: 480 x 800

scummVM installed on 16 GB microSD (Kingston, HC 2)

I first made a .lnk shortcut with a debug code 1 like this: 67#"\Lagringskort\Spill\Robin_Watts_ARM_STATIC_2009_21_07\scummvm.exe" -d1

This should produce two files: stdout and stderr, but none of these were generated (during subsequent testing), maybe it was compiled without debug features?

I started the .exe on the HTC TP2, and the startup screen placed itself in the upper left corner (image 1), I chose the AdvMAMEx2 then chose a game: FoA (image 2), after the intro I used the monkey which reverted the screen area back to the upper left corner (image 3) - note that the monkey is now horizontal, I then tried to press the monkey once more (image 4) - but this did not result in any orientation change (apart from the monkey - note that the monkey now is in vertical position). After quitting and starting the .exe again, the startupscreen opened in landscape mode (image 5), probably because the .ini file was created in the first execution. The same behaviour is reproducable after the creation of the .ini file as well. The mouse coursor is offset by a fifth of the width of the screen in x2 landscape mode (was so in the 0.13 release as well). A fifth to the left of the touch point on the screen. When the gamescreen is banished to the upper left corner, the touch point and mouse cursor behaviour is normal. Since the monkey rotation stops, it is no longer possible to rotate the landscape view 180 degrees. That was previously a 'sort of' solution to the mouse offset problem, because the mouse/click point coordination was normal in that landscape mode. Alas, I could not check the speed of the scaler, but hope this input was useful anyway. I have attached imagery and .ini files, but alas no stderr and stdout since they was not generated.

Ticket imported from: #2825332. Ticket imported from: feature-requests/543.

Attachments (6)

1startupscreen.jpg (9.2 KB ) - added by SF/pncfreak 10 years ago.
Start-up screen
2IndyFoA.jpg (18.6 KB ) - added by SF/pncfreak 10 years ago.
ARM AdvMAMEx2 chosen and FoA started
3UsingRotateMonkey.jpg (7.8 KB ) - added by SF/pncfreak 10 years ago.
Using rotation monkey
4UsingRotateMonkeyNoReaction.jpg (7.8 KB ) - added by SF/pncfreak 10 years ago.
No rotation when using monkey
5SecondStartupScreenAfterIniWasGenerated.jpg (17.3 KB ) - added by SF/pncfreak 10 years ago.
Second start-up screen after generating .ini file
scummvm.ini (2.5 KB ) - added by SF/pncfreak 10 years ago.
.ini file

Download all attachments as: .zip

Change History (12)

by SF/pncfreak, 10 years ago

Attachment: 1startupscreen.jpg added

Start-up screen

by SF/pncfreak, 10 years ago

Attachment: 2IndyFoA.jpg added

ARM AdvMAMEx2 chosen and FoA started

by SF/pncfreak, 10 years ago

Attachment: 3UsingRotateMonkey.jpg added

Using rotation monkey

by SF/pncfreak, 10 years ago

No rotation when using monkey

by SF/pncfreak, 10 years ago

Second start-up screen after generating .ini file

by SF/pncfreak, 10 years ago

Attachment: scummvm.ini added

.ini file

comment:1 by SF/robinwatts, 10 years ago

This is unrelated to the specific scaler used; the same thing happens with all the scalers I've tested it with. It looks to me like SDL is getting the screen (and mouse) offsets wrong.

I can reproduce this running under a VS2005 CE 5 pocket pc emulator set to a screen size of 480x800.

comment:2 by SF/robinwatts, 10 years ago

Summary: WinCE/PocketPC screen alignment and AdvMAMEx2WinCE/PocketPC screen alignment on WVGA devices with scalers

comment:3 by SF/pncfreak, 10 years ago

Well, my post here were deemed as an "unreadable blob of text" by sev in the IRC, so if a bug report should be posted it might be wise that someone else posts. Someone with a better penmanship than me.

Nice that you have located the source of the problem Robin!
Feel free to send me other test builds should you find the time to address the problem :)

comment:4 by sev-, 10 years ago

Closing as duplicate of #2825418 which has more readable description

comment:5 by sev-, 10 years ago

Owner: set to sev-
Resolution: duplicate
Status: newclosed

comment:6 by digitall, 12 months ago

Component: PortsPort: WinCE
Note: See TracTickets for help on using tickets.