Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#771 closed defect (invalid)

SAM: Missing drums with Adlib emu

Reported by: SF/mankeli Owned by: SF/jamieson630
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

Drum sounds are missing in ScummVM 0.4.1cvs, stock
0.3.0 and 0.3.7cvs.
However, all other games worked just fine.
And this only happens with Adlib emu.

Ticket imported from: #737622. Ticket imported from: bugs/771.

Change History (5)

comment:1 Changed 16 years ago by fingolfin

Owner: set to SF/jamieson630

comment:2 Changed 16 years ago by fingolfin

Any comments on this one, jamieson?

comment:3 Changed 16 years ago by SF/jamieson630

Resolution: invalid
Status: newclosed
Summary: Missing drums with Adlib emuSAM: Missing drums with Adlib emu

comment:4 Changed 16 years ago by SF/jamieson630

Drum sounds have never worked with Sam & Max under Adlib
emulation. It's documented in the code, and if we DO add it
later, it will be a feature, not a bug fix. Closing.

comment:5 Changed 16 years ago by SF/jamieson630

Okay, I closed this one, but.... Rudimentary percussion
support is implemented for Adlib. I only tested it with the first
couple scenes of Sam & Max; for some reason all my other
savegames are causing ScummVM to fault. (I could have
sworn several of them were from the modern era of "backward-
compatible savegame functionality", so I don't know why
ScummVM is having a fit over them.) Anyway, there's some
nice clicks and pops now, and that annoying "silence that is
supposed to be a drum solo" in the S&M intro credits now
actually has some bee-bop to it.

This is a WORK IN PROGRESS -- matching up Adlib
percussion instrument definitions to GM percussion keys is a
process that does not lend itself to automated support, so I'm
having to manually sift through 295 unclassified Adlib
instruments to try to figure out what they can be used for.
Bear with me.

Note: See TracTickets for help on using tickets.