Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#746 closed defect (fixed)

INDY3: Crash when loading new savegames

Reported by: eriktorbjorn Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

If I save a game in Indy 3, and then reload it ScummVM
crashes with the following message:

Assertion failed: _fontPtr, file scumm/charset.cpp, line 32

Strangely enough, loading older savegames works fine.

I don't know when this bug was introduced. Only that
it's present in today's snapshot, and in the April 21
snapshot which was the oldest one I still had on my
hard disk. I assume it's present in all the snapshots
in between as well.

A stack trace indicates that setCurID() was called by
drawString(), which was called by drawVerb(), but I
don't know if that's significant.

Ticket imported from: #730030. Ticket imported from: bugs/746.

Change History (8)

comment:1 Changed 16 years ago by SF/khalek

this same assertion is trigged in zak256 and the lfl based
fm towns demos now. reverting fingolfins changes to
string.cpp and resource_v3.cpp make them work again, but
still leave the problem mentioned in this bug report...

comment:2 Changed 16 years ago by SF/khalek

Owner: set to fingolfin

comment:3 Changed 16 years ago by SF/khalek

assigning to fingolfin as he asked to be notified of any
regressions the change could cause.

comment:4 Changed 16 years ago by fingolfin

Resolution: fixed
Status: newclosed

comment:5 Changed 16 years ago by SF/khalek

the fix broke several games so I made the resource part zak
dependent. Something very strange seems to be happening as
changing some things affects others it shouldn't.

the original bug is once again present in cvs
so reopening

comment:6 Changed 16 years ago by SF/khalek

Status: closednew

comment:7 Changed 16 years ago by fingolfin

Well, why did you make it Zak specific when the patch was meant for
both Zak and Indy, khalek? That makes no sense!

Anyway, for now I made the patch rtCharset specific, instead of
cheking for any particular game.

comment:8 Changed 16 years ago by fingolfin

Status: newclosed
Note: See TracTickets for help on using tickets.