Opened 16 years ago

Closed 15 years ago

Last modified 15 years ago

#745 closed defect (worksforme)

DIG: Asteroid Lander on the Pen Ultimate buggy

Reported by: SF/ubmax Owned by: aquadran
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

DIG: crash when starting Asteroid Lander on the Pen
Ultimate
ScummVM 0.3.7cvs on Win32 (Built on Apr 29 2003 12:51:11)

The Dig (German)

I click on the inventory, the Pen Ultimate, then on
"Asteroid Lander". That mini game doesn't start and
ScummVM crashes immediately.

Ticket imported from: #729641. Ticket imported from: bugs/745.

Change History (8)

comment:1 Changed 16 years ago by fingolfin

Owner: set to aquadran

comment:2 Changed 16 years ago by eriktorbjorn

Does this still happen? I can't reproduce it with the latest
CVS and the English version of The Dig.

comment:3 Changed 16 years ago by SF/ubmax

Using 0.4.2cvs built on Jun 10 2003 10:23:22 it doesn't
crash anymore. But after a successful landing the string
"%" is shown instead of the score.

comment:4 Changed 16 years ago by fingolfin

Summary: DIG: crash when starting Asteroid Lander on the Pen UltimateDIG: Asteroid Lander on the Pen Ultimate buggy

comment:5 Changed 16 years ago by SF/ubmax

Yes, it does still happen with the latest CVS (and the
German version of The Dig). Additionally the steering of the
lander doesn't work anymore.

comment:6 Changed 15 years ago by fingolfin

Resolution: worksforme
Status: newclosed

comment:7 Changed 15 years ago by fingolfin

I have been playing the asteroid lander a lot in the past couple
days (to debug vertical scrolling rooms), and I had no problems of
any kind (well except those introduced by all my experimental
changes, that is ;-).
Steering is done with the numpad, BTW. Not the arrow keys...

(All with latest ScummVM CVS).

comment:8 Changed 15 years ago by Kirben

Well there is still issue of final score not been shown,
although var is been set correctly.
And the lander crash messages are still often not cleared
correctly.
Or should I add new bug report for those ?

Note: See TracTickets for help on using tickets.