Opened 17 years ago

Closed 17 years ago

#707 closed defect (fixed)

MI2: Wrong palette during diving

Reported by: SF/yokitori Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

The ground near of the canon on the place of booty
island is purple wich should not be the case, I also
noticed wrong colors when diving to the ggaleon to take
the head of the monkey.
This happened with the CVS from 28 feb 2003, under
Win XP with monkey 2 french version.

Ticket imported from: #695654. Ticket imported from: bugs/707.

Attachments (7)

booty_island.png (92.6 KB ) - added by eriktorbjorn 17 years ago.
DOSEMU screenshot of Booty Island
diving1.png (55.8 KB ) - added by SF/yokitori 17 years ago.
Diving color bug
monkey2.s02 (52.9 KB ) - added by SF/yokitori 17 years ago.
just before diving state
diving1.2.png (55.8 KB ) - added by SF/yokitori 17 years ago.
Wel this is another shot, just a few frames later,just before the end of the bug
diving2.png (40.8 KB ) - added by SF/yokitori 17 years ago.
well I clicked on the wrong file and it doesn't seems to want to delete it.…
SAVEGAME.003 (39.1 KB ) - added by SF/yokitori 17 years ago.
original MI2 sazvegame before diving.…
mi2-diving-fix.diff (446 bytes ) - added by eriktorbjorn 17 years ago.
Patch against an April 2 CVS snapshot

Download all attachments as: .zip

Change History (26)

comment:1 by fingolfin, 17 years ago

Summary: Wrong palette on Booty IslandMI2: Wrong palette on Booty Island

comment:2 by fingolfin, 17 years ago

Owner: set to eriktorbjorn

comment:3 by fingolfin, 17 years ago

Assigning to erik, maybe he has a good idea...

comment:4 by eriktorbjorn, 17 years ago

It isn't obvious to me that it is a bug -- it could be just
the shadow from the trees. Could someone please try it with
the original interpreter?

I did find a screenshot at
http://adventurecorner.daddeltreff.de/monkey/screenshots/monkey2/image017.jpg
but I suppose it's possible that it was made with ScummVM...

by eriktorbjorn, 17 years ago

Attachment: booty_island.png added

DOSEMU screenshot of Booty Island

comment:5 by eriktorbjorn, 17 years ago

Here's a screenshot of what Booty Island looks like when
running the original interpreter in DOSEMU. I don't have any
good savegame within reach, but isn't this pretty much
identical to how ScummVM renders it?

I haven't looked at the diving scene recently either way.
Andra, could you make a screenshot of it and describe more
precisely what's wrong?

comment:6 by fingolfin, 17 years ago

I concur, this doesn't seem like a bug to me... so if you like, close this as "Invalid" or so :-)

comment:7 by eriktorbjorn, 17 years ago

I'd say the first half is invalid, yes. It's tempting to
close it, but it'd be nice to have the second half
investigated before dismissing it completely.

Though there is *no* *way* I'm going to play that far in
DOSEMU. It's painful to use, and I haven't been able to get
it to save. Maybe if I can get some savegames I just
downloaded to work with DOSEMU or DOSBox, but not otherwise.

Of course, I'd still need a better description of the problem.

comment:8 by fingolfin, 17 years ago

Did you try with dosbox, actually? It works really great on my PowerMac; I'd try this myself, but I don't own the PC version of Monkey Island 2...

Anyway, I hope Andra will get back to us and comment...

comment:9 by SF/yokitori, 17 years ago

Well if the color near of the canon may not be a bug (I want to
check it, but have to install a valid dos on my PC) there really
is a color bug while diving (with the cvs from 03-29-2003) I join
a state just before diving and a screen shot ....
Sorry for the long time with no response....

by SF/yokitori, 17 years ago

Attachment: diving1.png added

Diving color bug

by SF/yokitori, 17 years ago

Attachment: monkey2.s02 added

just before diving state

comment:10 by SF/yokitori, 17 years ago

As you can see on the shot, there are some
red/orange/yellow colors wich are NOT in the original game,
i'm pretty sure of it....

comment:11 by SF/yokitori, 17 years ago

Ok for the booty shadow near of the canon I must admit I was
wrong, I tested it, it actually IS purple, but under pure DOS it
looked a little brighter and thus maked it not so shocking asit
seemed to me in scummvm, but it is most likely an question
of monitor settings under windows and NOT a bug... I'm sorry.
But for the diving it IS a bug....

comment:12 by fingolfin, 17 years ago

Owner: eriktorbjorn removed
Summary: MI2: Wrong palette on Booty IslandMI2: Wrong palette during diving

comment:13 by fingolfin, 17 years ago

Sadly I can't load the save game you attached :-/ Will have to play till that point on my own.

by SF/yokitori, 17 years ago

Attachment: diving1.2.png added

Wel this is another shot, just a few frames later,just before the end of the bug

comment:14 by SF/yokitori, 17 years ago

Well, I post a new shot, just a little later than the first, so you
can see the "whole" bug. By this I mean the image is basicly
a scroling, and on that new shot you see all the "wrong
palletized" image and just after it it get back to normal, with
a blue water instaed of that orange water....

by SF/yokitori, 17 years ago

Attachment: diving2.png added

well I clicked on the wrong file and it doesn't seems to want to delete it....

comment:15 by eriktorbjorn, 17 years ago

> Did you try with dosbox, actually?

That's what I tried first, but it crashed early in the game
on some unsupported feature. Maybe the CVS version of DOSBox
works better.

I couldn't get the savegames to work in DOSEMU, by the way.
Oh well...

by SF/yokitori, 17 years ago

Attachment: SAVEGAME.003 added

original MI2 sazvegame before diving....

comment:16 by SF/yokitori, 17 years ago

Well, I don't have DOSemu, but I just tried in pure DOS and I
can tell you it is really a bug... I'm joining an original Monkey2
savegame just before dicing, but I don't know if it'll load if you
don't have the french version (surely you know it better than
me)

by eriktorbjorn, 17 years ago

Attachment: mi2-diving-fix.diff added

Patch against an April 2 CVS snapshot

comment:17 by eriktorbjorn, 17 years ago

With ScummVM, you can get to the diving scene by using the
debugger to go to room 63. You won't find the galleon, but
you should see the palette bug. It goes away if I call
updatePalette() first thing in scrollEffect(). I'll attach a
patch, trivial though it may be.

I didn't even know MI2 used this function. I don't think it
was implemented the last time I played this scene, and I
assumed it was added just for the thunderstorm scene in DOTT.

Oh, and the latest release of DOSbox (0.58) seems to have
fixed the MI2 crash.

comment:18 by fingolfin, 17 years ago

Owner: set to eriktorbjorn
Resolution: fixed
Status: newclosed

comment:19 by fingolfin, 17 years ago

Fixed by a patch based on erik's patch :-)

Note: See TracTickets for help on using tickets.