Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#7035 closed defect (fixed)

AGI Fanmade no intro sound

Reported by: SF/necros2014 Owned by: m-kiewitz
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: AGI Fanmade

Description

Al Pond
Sorceror`s appraisal

Ticket imported from: bugs/7035.

Change History (2)

comment:1 Changed 3 years ago by m-kiewitz

Owner: set to m-kiewitz
Resolution: fixed
Status: newclosed

comment:2 Changed 3 years ago by m-kiewitz

This is caused by those games setting volume to 15, which in AGI means "mute".
I just added a heuristic to detect such games. When this is triggered, the volume will get interpreted by us in the wrong way (15 loudest, 0 mute). I can't test all of them, but for Sorceror's Appraisal it worked fine.

Volume was not used by us until recently, that's why this showed up now.

Commit 4ad1bbf108ac408be0ae7d53768d040fd9e32500

Note: See TracTickets for help on using tickets.