Opened 4 years ago

Closed 4 years ago

#7034 closed defect (fixed)

AGI: Space Quest 2 priority issue (Apple IIgs only)

Reported by: m-kiewitz Owned by: m-kiewitz
Priority: normal Component: Engine: AGI
Keywords: Cc:
Game: Space Quest 2

Description

I played through the game today and found a priority issue at the end of the game.
Caused by the game scripts calling set.pri.base(42), right when entering Vohaul's secret room.

DOS Space Quest 2 does not do that. Strangely no priority issue happens when being using emulator + original interpreter. Priority of ego is also different. It almost seems as if the set.pri.base call isn't really processed by the original Apple IIgs interpreter.

This causes not only issues in the secret room, but the follow-up rooms also have small priority issues because of it.

Adding ticket, so that it's documented.

Vohaul's secret room is room 86, follow up rooms are 90 + 91.

Ticket imported from: bugs/7034.

Change History (2)

comment:1 by m-kiewitz, 4 years ago

Somewhat solved by commit 736d7cd533255d1fa9b3a6d20158ed7c917ac4a6
Still needs to get fully figured out

comment:2 by m-kiewitz, 4 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.