Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#697 closed defect (fixed)

INDY3: usage_bits crash

Reported by: SF/phako Owned by: eriktorbjorn
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 3

Description

Crash occures on cvs checkout from today (18.02.2003)
but also in an earlier checkout with 256 col. german
version of the game, running on Debian/testing Linux,
compiler gcc 2.95.4

Reproduce by walking through the corridor next to indy
(the rightmost), savegame attached.

-------------------------------------------
ScummVM 0.3.1cvs
Built on Feb 18 2003 23:13:55
-------------------------------------------

jgeorg@newton:~/simon/indi3$ scummvm -p . indy3
Looking for indy3
Trying to start game 'Indiana Jones and the Last
Crusade (256)', version 3.0.22
Allocated 200 space in numObjects
scummvm: scumm/usage_bits.cpp:42: void
Scumm::setGfxUsageBit(int, int): Assertion `1 <= bit &&
bit <= 96' failed.
Abgebrochen (core dumped)
--------------------------------------------
Backtrace:
(gdb) bt
#0 0x4014b581 in kill () from /lib/libc.so.6
#1 0x4009594e in pthread_kill () from /lib/libpthread.so.0
#2 0x40095e29 in raise () from /lib/libpthread.so.0
#3 0x4014c8d1 in abort () from /lib/libc.so.6
#4 0x40145db2 in __assert_fail () from /lib/libc.so.6
#5 0x0808b271 in strcpy ()
#6 0x08067111 in strcpy ()
#7 0x08067958 in strcpy ()
#8 0x0804ecb2 in strcpy ()
#9 0x08050f99 in strcpy ()
#10 0x08051178 in strcpy ()
#11 0x0809c7bf in strcpy ()
#12 0x4013b0bf in __libc_start_main () from /lib/libc.so.6

Ticket imported from: #689095. Ticket imported from: bugs/697.

Attachments (1)

indy3.s03 (41.2 KB) - added by SF/phako 16 years ago.
Savegame to reproduce the error

Download all attachments as: .zip

Change History (6)

comment:1 Changed 16 years ago by SF/khalek

it would appear the savegame isn't attached please try again

comment:2 Changed 16 years ago by SF/khalek

Summary: Crash in Venice if Indy enters right corridorINDY3: usage_bits crash

Changed 16 years ago by SF/phako

Attachment: indy3.s03 added

Savegame to reproduce the error

comment:3 Changed 16 years ago by SF/phako

sorry, seems to be a problem with mozilla, here it comes

comment:4 Changed 16 years ago by fingolfin

Resolution: fixed
Status: newclosed

comment:5 Changed 16 years ago by fingolfin

Owner: set to eriktorbjorn
Note: See TracTickets for help on using tickets.