Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6771 closed defect (fixed)

ZVISION: Unable to leave room after loading saved game

Reported by: eriktorbjorn Owned by: bluegr
Priority: normal Component: Engine: ZVision
Keywords: Cc:
Game: Zork Grand Inquisitor

Description

Current Git snapshot of ScummVM, English version of the game.

I saved while looking out the window in the Dungeon Master's hideout. After loading that savegame, I'm unable to leave the room. I do get an arrow cursor indicating that I should be able to move, but nothing happens when I click it.

I'm attaching a savegame near the window, and one while looking out. To reproduce, simply use the first savegame, look out the window and save there.

Ticket imported from: bugs/6771.

Attachments (2)

zgi-win.017 (23.1 KB) - added by eriktorbjorn 5 years ago.
zgi-win.018 (20.2 KB) - added by eriktorbjorn 5 years ago.

Download all attachments as: .zip

Change History (12)

Changed 5 years ago by eriktorbjorn

Attachment: zgi-win.018 added

comment:1 Changed 5 years ago by eriktorbjorn

I think what happens is that the hotspot to leave the room is wired to location '0' '0' '0' '0' 0, which means "return to previous location". When I walk up to the window, the this works fine. When I load the savegame, it seems like changeLocation() sets up the current room as the previous location.

So the hotspot is handled correctly, it's just that it has forgotten what the previous location really was.

comment:2 Changed 5 years ago by eriktorbjorn

Whatever fix is made for this, it probably has to be tested with both the original and the ScummVM save/load dialogs.

comment:3 Changed 5 years ago by eriktorbjorn

I've removed my debug messages, but I probably meant to write that it's changeLocationReal() that sets up the current room as the previous location, not changeLocation().

comment:4 Changed 5 years ago by RichieSams

Fixed in commit b835eacc0

comment:5 Changed 5 years ago by RichieSams

Resolution: fixed

comment:6 Changed 5 years ago by RichieSams

Fixed a regression with commit 3a31e1de

comment:7 Changed 5 years ago by eriktorbjorn

Are you sure it's fixed? I'm still stuck at that window, after saving/restoring at it, regardless of whether I'm using the original save/restore dialogs or ScummVM's.

comment:8 Changed 5 years ago by eriktorbjorn

Resolution: fixed

comment:9 Changed 5 years ago by eriktorbjorn

This seems to be working now. (When I filed the bug report I assumed it would be fairly easy to fix, but apparently it was trickier than I would have guessed.)

comment:10 Changed 5 years ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:11 Changed 5 years ago by bluegr

Thanks for your report eriktorbjorn!

Yeah the bug is fixed now, with commits dcac5be493, 5df2e08c16 and 5f9858844a. Turned out to be a bit trickier than expected.

I've tried it with both the original and the ScummVM save/load screens, it's working correctly now.

Closing as fixed

Note: See TracTickets for help on using tickets.