Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6768 closed defect (fixed)

ZVISION: Game will not save during prison sequence

Reported by: SF/tnm23 Owned by: bluegr
Priority: normal Component: Engine: ZVision
Keywords: Cc:
Game: Zork Grand Inquisitor

Description

Scummvm version: ScummVM 1.8.0git (Jan 16 2015 10:31:43)
Features compiled in: TAINTED Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG Optimised/Release build.

Bug details: Whilst in the prison cell or the control area outside it, attempting to save the game will appear to work without error or fault, but will not actually create a save file. The game can be saved properly before or after the prison sequence.

English language edition of ZGI, 2 CD release. Installed under wine, official patch applied, then all required files copied into /usr/share/scummvm/zgi

Debian Wheezy 7.8, Kernel 3.2.0-4-amd64 (#1 SMP Debian 3.2.65-1), gcc version 4.7 (x86_64-linux-gnu)

Steps to reproduce: Play as normal until the prison area. Save game. Attempt to load save file just produced.

Ticket imported from: bugs/6768.

Attachments (1)

zgi-win.015 (24.5 KB) - added by SF/tnm23 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by SF/tnm23

Attachment: zgi-win.015 added

comment:1 Changed 5 years ago by bluegr

I can't reproduce this. I'm using the ScummVM save/load dialogs. I've just beaten the rock-paper-shotgun game, exited the castle, entered the cell and saved. The game is saved, and I can load it just fine...

I'm also using the 2CD release

Perhaps it's something else? Have you installed the game patch?

comment:2 Changed 5 years ago by SF/tnm23

EDIT: I originally posted my reply as a new comment by accident, when I meant to post in direct reply to FK. Unfortunately, having appropriately moved my reply, I now don't seem to be able to delete this post! Somebody with the power to do so, please delete this.

comment:3 Changed 5 years ago by SF/tnm23

Interesting - I've just checked, and the bug only happens when using the original save/load dialogues. It's fine when using the scummvm one. I am using the patched game.

comment:4 Changed 5 years ago by digitall

Summary: Game will not save during prison sequenceZVISION: Game will not save during prison sequence

comment:5 Changed 5 years ago by bluegr

Owner: set to bluegr
Resolution: fixed
Status: newclosed

comment:6 Changed 5 years ago by bluegr

Ah, now I managed to reproduce this. The bug only manifested when using the original save/load screens.

Fixed in commit 68b7839d99.

The fix will be available in the next daily version of ScummVM

Note: See TracTickets for help on using tickets.