Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6676 closed defect (fixed)

GOB: Duplicate Detection Entries For Ween/DOS/English

Reported by: SF/caboose684 Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Ween

Description

$ scummvm -v
ScummVM 1.6.0 (Aug 8 2013 12:11:07)
Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib FluidSynth Theora

Platform: Linux (xubuntu 14.04 x86), from distro repository

Game: Ween: The Prophecy (DOS/English (US))

Description:
On Mass Add, it gets added twice. On Add Game, a selection is offered. Both entries are identical.

It appears that the DOS VGA Floppy section is duplicated in engines/gob/detection/tables_ween.h. Once at the beginning of the file (lines 28-113) and once in the middle (lines 231-316). According to diff, they're identical.

A brief check on the github master branch suggests the file is unchanged. The section is there twice, anyway. I didn't pull to run a diff.

Ticket imported from: bugs/6676.

Change History (4)

comment:1 by digitall, 5 years ago

Owner: set to DrMcCoy
Summary: Duplicate entries on Mass Add or Add GameGOB: Duplicate Detection Entries For Ween/DOS/English

comment:2 by digitall, 5 years ago

Confirmed in latest git master. See:
https://github.com/scummvm/scummvm/blob/master/engines/gob/detection/tables_ween.h#L28-113
vs.
https://github.com/scummvm/scummvm/blob/master/engines/gob/detection/tables_ween.h#L231-316

This looks like a cut and paste error. One of the blocks should be deleted. Probably the first.

comment:3 by DrMcCoy, 5 years ago

Resolution: fixed
Status: newclosed

comment:4 by DrMcCoy, 5 years ago

Yeah, I guess that happened when I sorted the entries by platform after I split up that big detection table. That's why you're wrong: the second block should be removed.

And I did just that in 24595ed.

Note: See TracTickets for help on using tickets.