Opened 5 years ago

Closed 16 months ago

#6675 closed defect (duplicate)

ANDROID: SCUMM MI2 - Music Audio Distorted

Reported by: SF/deejaydiabolik Owned by: csnover
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

I have try to play Monkey Island 2 from my Android Smartphone (OnePlus One 64GB):
I have installed the latest daily build and the latest plugins for scumm engine.. the games started whitout problems bit the audio appears Luke disturbing or distorted.
i have try to turno low the volume on device but the problems still remain.

Monkeys Islands 2 it's the italian CD version and i nave copied alla file from my PC to my smartphone.....

Ticket imported from: bugs/6675.

Attachments (1)

7Urp5X3.png (44.6 KB) - added by digitall 5 years ago.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 5 years ago by digitall

deejaydiabolik: Some things will be needed to progress this bug report:
1. Can you give the exact version of the Android daily build you used please? This is listed in the Credits and below the ScummVM logo on the launcher i.e. ScummVM 1.8.0git14-gd8f16fa-dirty (Jul 2 2014 14:24:14)

  1. Can you please try this with the same datafiles on the latest daily build on a desktop build i.e. Win32/Mac OSX/Linux to see if the same effect occurs or if the problem is specific to Android.

  2. Can you confirm the settings in Options->Audio for Global and whether the Monkey Island 2 is set as per the global defaults? Specifically are you using Adlib as the Preferred Device?

comment:2 Changed 5 years ago by digitall

  1. Can you add a text files to this bug with a file listing of your Monkey Island 2 Italian datafiles with file MD5sums? This will allow us to eliminate variant or corrupted datafiles as a possible cause of this issue.

  2. Could you attach a small (< 250Kb) mp3 file of the "distorted" music audio and preferably another one with the "correct" music from a desktop / v1.6.0 build?

  3. Can you confirm if this occurs with the same datafiles on earlier builds for Android i.e. v1.5.0 in Google Play store, earlier v1.6.0 daily builds? If not, then please give the exact version of the "good" revision and we can look at producing builds for you to "bisect" this issue.

comment:3 Changed 5 years ago by digitall

Summary: Monkey Island 2 - Audio distorted or disturbed..SCUMM / ANDROID: MI2 - Music Audio Distorted

comment:4 Changed 5 years ago by digitall

Status: newpending

comment:5 Changed 5 years ago by digitall

Just did a quick check on Linux x86_64 with Monkey Island 2 (English) on v1.6.0 and latest git master. No obvious difference in music / sound output.

deejaydiabolik: Please do the things indicated earlier, but suspect the issue is in your Audio settings, so for Point 2., amend to "please provide a full listing of your audio settings for Monkey Island 2 preferably as a screen shot of that option tab".

comment:6 Changed 5 years ago by SF/deejaydiabolik

Ok.. sorry for later response.....
1) I have updated yesterday my dailyduild version on my Android Device:
ScummVM 1.8.0git37-gc4d685b (Jul 6 2014 08:53:1)

2) on Global Option -> Audio i have all selected the default on all value.. i have take a screenshot:
http://i.imgur.com/7Urp5X3.png

3) On my device i have try to registered a part of the games using screencast... but i can do obtain a good registration.. i need to understand how i can registred a parts of audio.

4) I can post a MD5 about my files... but i have used the same files on my Destkop PC and the audio it's fine.... i thinks it's a problems on Android devices... i have also try to play on another Android Device like my brothers Samsung Note 2 whit latest stock ROM and same appened problems on audio....

Ask if you want and i can obtain all information.... for example i can post some savegames i have found some parts when this distorted it's very clearly to listen....

comment:7 Changed 5 years ago by SF/deejaydiabolik

Oh yeah... using Screencast i have maked a little video about my Screen of my Phone and play the last parts of Monkey Island 2 this is MediaInfo about this file:

General
Complete name : C:\Users\Diabolik-Win7\Desktop\Screencast_2014-07-07-12-36-34.mp4
Format : MPEG-4
Format profile : Base Media
Codec ID : isom
File size : 31.2 MiB
Duration : 46s 605ms
Overall bit rate : 5 625 Kbps
Encoded date : UTC 2014-07-07 10:37:21
Tagged date : UTC 2014-07-07 10:37:21

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : Baseline@L5.0
Format settings, CABAC : No
Format settings, ReFrames : 1 frame
Format settings, GOP : M=1, N=91
Muxing mode : Container profile=High@1.3
Codec ID : avc1
Codec ID/Info : Advanced Video Coding
Duration : 46s 569ms
Source duration : 46s 735ms
Bit rate : 5 511 Kbps
Width : 1 080 pixels
Height : 1 920 pixels
Display aspect ratio : 0.563
Frame rate mode : Variable
Frame rate : 29.272 fps
Minimum frame rate : 0.301 fps
Maximum frame rate : 218.978 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.091
Stream size : 30.6 MiB (98%)
Source stream size : 30.9 MiB (99%)
Title : VideoHandle
Language : English
Encoded date : UTC 2014-07-07 10:37:21
Tagged date : UTC 2014-07-07 10:37:21
mdhd_Duration : 46569

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : 40
Duration : 46s 605ms
Bit rate mode : Constant
Bit rate : 63.8 Kbps
Nominal bit rate : 96.0 Kbps
Channel(s) : 1 channel
Channel positions : Front: C
Sampling rate : 22.05 KHz
Compression mode : Lossy
Stream size : 363 KiB (1%)
Title : SoundHandle
Language : English
Encoded date : UTC 2014-07-07 10:37:21
Tagged date : UTC 2014-07-07 10:37:21

Take about 10 minutes to upload on Host services... and i can post download links...

comment:8 Changed 5 years ago by SF/deejaydiabolik

And this is the download links for screencast regged from my Android Device:
http://mir.cr/P8XMXWSH

Thanks for support and i hope this is usefull for resolve this little problems...

comment:9 Changed 5 years ago by SF/deejaydiabolik

You can explain how i can found and edit the scummvm.ini on my Android Device ?

I have rooted my phone and i can access on all folder but i can't found this file... you can help me ?

comment:10 Changed 5 years ago by digitall

Summary: SCUMM / ANDROID: MI2 - Music Audio DistortedANDROID: SCUMM MI2 - Music Audio Distorted

comment:11 Changed 5 years ago by digitall

Status: pendingnew

comment:12 Changed 5 years ago by digitall

SIGH. Right, firstly " how i can found and edit the scummvm.ini on my Android Device" is off topic... but basically it is a) find your scummvm.ini file with a File Manager (I recommend GhostCommander) and then b) edit it with a text editor, but frankly DO NOT DO THIS. You should be able to change any settings you need via the ScummVM Launcher GUI and a malformed ini file is too easy if you don't know what you are doing.

comment:13 Changed 5 years ago by digitall

Secondly, DO NOT use external file storage services. It takes us a while to get round to fixing bugs and by then, the links are broken. Keep files less than 256K and upload to this bug with "Add attachments" instead.

Changed 5 years ago by digitall

Attachment: 7Urp5X3.png added

comment:14 Changed 5 years ago by digitall

Added file previously linked by submitter to avoid future link breakage.

comment:15 Changed 5 years ago by digitall

Can't upload the screencast as it is 31 MB and the service is some kind of crap which needs an account to get at the video.

comment:16 Changed 5 years ago by digitall

To repeat my previous request:
Can you add a text files to this bug with a file listing of your Monkey Island 2 Italian datafiles with file MD5sums? This will allow us to eliminate variant or corrupted datafiles as a possible cause of this issue.

Could you attach a small (< 250Kb) mp3 file of the "distorted" music audio and preferably another one with the "correct" music from a desktop / v1.6.0 build?

Can you confirm if this occurs with the same datafiles on earlier builds for Android i.e. v1.5.0 in Google Play store, earlier v1.6.0 daily builds? If not, then please give the exact version of the "good" revision and we can look at producing builds for you to "bisect" this issue.

comment:17 Changed 5 years ago by SF/deejaydiabolik

you don't need a account for download this video!! Just opening the correct mirror:

http://www68.zippyshare.com/v/70831611/file.html

comment:18 Changed 5 years ago by SF/deejaydiabolik

For mp3... i have uploaded the Screencast video.

  • For MD4sums... how i need to do to obtain and what's it the exact file name i need to check for you.

  • YEAH... the same "problems" it's present whit the version 1.5.0 in Google Play Store and whit the today nightly build.

comment:19 Changed 5 years ago by SF/deejaydiabolik

http://bayfiles.net/file/1hgYL/1LxSek/Screencast_2014-07-07-12-36-34.mp4

Can download here after press on "Premium Download" whitout any time of account.

comment:20 Changed 5 years ago by SF/deejaydiabolik

http://www.solidfiles.com/d/4edb1b1c7e/Screencast_2014-07-07-12-36-34.mp4

You can also use this........ Press on "Direct Download Link" under the green download button.

It's doesn't need any time of account.......

comment:21 Changed 5 years ago by SF/deejaydiabolik

Ok... i have found a possibly SOLUTION or WORKAROUND!

The DEFAULT volume of SCUMMVM apps it's 192 for all three voices...... for not obtain this distorsion it's simply neeeded to TURN DOWN THE VOLUME at about 170!!

And all distorsion disappered!!!

I don't know..... because i obtain this distorsion.... i obtain this only whit MONKEY ISLAND 2 because on my One Plus One i have played all Monkey Island 1 whitout problems and whit audio volume setted to 192 without problems.

Now... if we need again the MD5 Checksum.. please again say to me how i can obtain and if we need this check on all file or put a filelist...

comment:22 Changed 16 months ago by csnover

Owner: set to csnover
Resolution: duplicate
Status: newclosed

I’m fairly confident that this is either a duplicate of #6957 or a single-device issue. Probably the first one, so I’m closing this ticket as a duplicate for that other issue.

Note: See TracTickets for help on using tickets.