Opened 5 years ago

Closed 5 years ago

#6620 closed defect (duplicate)

RINGWORLD2: F5 to save doesn't work the first time

Reported by: eriktorbjorn Owned by:
Priority: normal Component: Engine: TsAGE
Keywords: Cc:
Game: Return to Ringworld

Description

Here's what I did:

1) I started the game.
2) I immediately restored a savegame (while I was still on the Tsunami logo screen)
3) I immediately hit F5 to save.

But it didn't save my game. Instead I was thrown back to the save dialog again. The second time, it worked.

Some observations:

The first time the dialog opened, it was because processEvent() in ringworld2_logic.cpp called saveGame(). The second time, it was because SceneHandler::process() in core.cpp called saveGame().

Presumably, it never got the chance to act on the save slot and name set by the first call to saveGame(). I haven't tried to figure out more precisely what happens, though.

Ticket imported from: bugs/6620.

Change History (1)

comment:1 by eriktorbjorn, 5 years ago

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.