Opened 5 years ago

Closed 5 years ago

#6615 closed defect (fixed)

SCI: LB2 - End-of-Act-IV transition music not playing

Reported by: SF/boneosaurusrex Owned by: wjp
Priority: normal Component: Engine: SCI
Keywords: Cc:
Game: Laura Bow 2: The Dagger of Amon-Ra

Description

ScummVM is not playing the transition music that's supposed to play at the very end of Act IV, right before the Act V title screen.

The end of Act IV is triggered by leaving Olympia's office after inspecting the body of the Countess and picking up the grapes. After you walk off screen the game plays a piece of Egyptian transition music, resource 524.snd, which is the only time this music is played. When it's done the Act V title screen appears.

ScummVM isn't playing this track but it is pausing the game for the correct duration (~6 seconds) before transitioning to the Act V title screen. I'm seeing this in both floppy and CD versions. I believe this to be a regression.

I've included ScummVM save games of floppy and CD versions. In both of these, the player is in Olympia's office but hasn't picked up the grapes yet from the body. This is so that you can still walk around the museum if you need to trigger other music to reset the state or something. (I'm just imagining things that would help debug.) All you need to do to reproduce the issue is to look at the body, pick up the grapes, and leave the room. The game will pause but not play the music.

Sometimes, when I restore from certain save games, the transition music does play. I don't know if that's a result of those games being saved from builds several months ago or what. In the attached save games I had started much earlier in the game using the current build before saving, so I believe them to be accurate and not tainted by version mismatch. Let me know if I can provide anything to else to help.

Tested with latest Win32 build.

Ticket imported from: bugs/6615.

Attachments (2)

laurabow2.011 (49.6 KB ) - added by SF/boneosaurusrex 5 years ago.
laurabow2-cd.037 (52.8 KB ) - added by SF/boneosaurusrex 5 years ago.

Download all attachments as: .zip

Change History (7)

by SF/boneosaurusrex, 5 years ago

Attachment: laurabow2-cd.037 added

comment:1 by bluegr, 5 years ago

Component: Engine: SCI
Game: Laura Bow 2: The Dagger of Amon-Ra

comment:2 by wjp, 5 years ago

On the remapper-level, this song isn't playing because there aren't enough voices for it to play while the current song is still playing at the same time.

I'm not yet sure if the other song should have been stopped first, or if this is a bug in remapper behaviour.

comment:3 by wjp, 5 years ago

I should probably add that we've had quite a few bugs of songs staying stuck in LB2, so it wouldn't be too surprising if we're still doing something wrong there.

comment:4 by wjp, 5 years ago

This is probably caused by us not handling relative song priority correctly when two songs have the same priority. I have a work-in-progress fix in my sci_amiga branch at https://github.com/wjp/scummvm/commits/sci_amiga . I hope it'll be ready for inclusion in master soonish.

comment:5 by wjp, 5 years ago

This branch is now merged.

comment:6 by wjp, 5 years ago

Owner: set to wjp
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.