Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6614 closed defect (fixed)

SCI: HOYLE4 - textbox in wrong position

Reported by: misterhands Owned by: m-kiewitz
Priority: normal Component: Engine: SCI
Keywords: script Cc:
Game: Hoyle's Classic Card Games

Description

Using a recent Win32 build by Kirben Hoyle 4 DOS

In the Bridge save hand dialog, the text box is not placed properly. Please see the pics. This affects the restore hand dialog as well.

Ticket imported from: bugs/6614.

Attachments (2)

DOSBox.png (20.4 KB ) - added by misterhands 6 years ago.
ScummVM.png (19.9 KB ) - added by misterhands 6 years ago.

Download all attachments as: .zip

Change History (3)

by misterhands, 6 years ago

Attachment: DOSBox.png added

comment:1 by m-kiewitz, 6 years ago

I didn't fix this properly the last time.

This behaviour is actually caused by a script bug. The script for the edit control does uninitialized reads and the text control, that is initialized before that, writes its coordinates at that position in SSCI. Which means it just works by accident in SSCI.

I've just adjusted the returned values for those uninitialized reads, so that the edit control is placed at the exact same position as in SSCI.

Commit 3f7566c7b183452a6203140b923d7e7a273369dd

comment:2 by m-kiewitz, 6 years ago

Keywords: script added
Owner: set to m-kiewitz
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.