Opened 6 years ago

Closed 4 years ago

#6552 closed defect

COMI: Music is jumping

Reported by: SF/thunderpeel2001 Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

I wonder if there's been a regression? I'm playing through COMI on 1.6.0 and the music has been consistently intermittently jumping. I've been playing it for about a week now, and it's all through the game, every island. It's very jarring and noticeable.

My machine is more than powerful enough to be playing COMI through ScummVM. I have a Core i7 with 16GB of RAM, and NEVER experience sound issues with any other game.

I took a recording of what it sounds like. This is immediately what I heard when unpausing the game. It only took 20 seconds to hear an example of the music jumping:

https://dl.dropboxusercontent.com/u/30449117/COMI-MusicJumping.mp3 (Jump is heard at 0:20)

I really hope there's some way to fix this. Thanks!

ScummVM version: 1.6.0 Language of game: English Platform: Windows 8.1

Ticket imported from: bugs/6552.

Attachments (2)

comi.s15 (82.8 KB ) - added by SF/thunderpeel2001 6 years ago.
comi.s21 (85.7 KB ) - added by SF/thunderpeel2001 6 years ago.

Download all attachments as: .zip

Change History (15)

by SF/thunderpeel2001, 6 years ago

Attachment: comi.s15 added

comment:1 by SF/thunderpeel2001, 6 years ago

Just to add what version I'm playing: I simply pulled the files off my original COMI CDs. I have not altered the game in any way.

comment:2 by digitall, 6 years ago

@thunderpeel2001: To progress this bug, we will need you to provide some further information and do some basic debugging for us:

  1. Please attach a text file to this bug containing a file listing of your CoMI datafiles and their MD5sums. The output of a tool such as http://www.md5summer.org/ would be optimal... This allows us to compare and eliminate corrupted or variant datafiles as a possible cause of this.

  2. Please test with the latest nightly build from here: http://www.scummvm.org/downloads/#daily Please try both Kirben's Win32 nightly and the latest Buildbot Win32 build. Please note here if the problem is still occurring with this.

  3. If the problem is still occurring, please run them with ./scummvm -d 1 and copy the initial warning/debug output from the ScummVM console window here... Specifically the SDL audio and video drivers being used are of interest. It would also be good to note what Audio card you have in your machine.

comment:3 by digitall, 6 years ago

It has been noted by fuzzie that this may be related to bug #5894 "The Dig: Audio pops between (in)scene changes" : https://sourceforge.net/p/scummvm/bugs/5894/

But this bug is mainly an issue on Android... so will see if we can eliminate the more obvious causes with Win32 audio drivers / SDL before we investigate the SCUMM engine IMUSE as possible cause...

comment:4 by digitall, 6 years ago

@thunderpeel2001: Also, if this still occurs on the latest nightly, it would be useful for you to try v1.5.0, v1.4.1 etc. to see if this occurred in earlier versions or if this is a recent regression in the SCUMM IMUSE for CoMI... Thanks in advance.

comment:5 by SF/thunderpeel2001, 6 years ago

One great place it happens consistently is when looking at the portrait of El Pollo Diablo in Blondebeard's shop. I'll check the nightly build.

Here's my MD5s:

ff9f5d3d05e72bada4ba1f8849352cf7 *RESOURCE/BBSAN.SAN
6cceb9586037e325f429836efbfd12c5 *RESOURCE/CURSERNG.SAN
e4fcdbd3487886a06d56492696fd1c84 *RESOURCE/FG010GP.SAN
953a1221941e53c5b7ae0c4f99395064 *RESOURCE/FINALE.SAN
8b9f2180203fad6fbe22db9a48b6a839 *RESOURCE/FONT0.NUT
c5c8e3a0ab861b38f9805fbc16f62550 *RESOURCE/FONT1.NUT
c5c8e3a0ab861b38f9805fbc16f62550 *RESOURCE/FONT2.NUT
90d178dacab8dd14c40e61005131d118 *RESOURCE/FONT3.NUT
97a7d3fb528f16e86cf3970ace75e66c *RESOURCE/FONT4.NUT
71725a54a64252628c6b021341520632 *RESOURCE/KIS030.SAN
2daf3db71d23d99d19fc9a544fcf6431 *RESOURCE/LANGUAGE.TAB
7d0ad52e7fe32d819edf8c6095adbedf *RESOURCE/LAVARIDE.SAN
ec2d9d57148e21f46896a359b239fcf4 *RESOURCE/LIFTCRSE.SAN
214d0a3b9c8fffc77cc35be8a0101d03 *RESOURCE/MORESLAW.SAN
9e662f111ae0cdf9f68c594475a891a2 *RESOURCE/MUSDISK1.BUN
3ed44debfb6ce1de6a2cd99f4ed0c408 *RESOURCE/MUSDISK2.BUN
dd7b5beaa17e4eebb896ddbca9ffb2f0 *RESOURCE/NEWBOOTS.SAN
833ba64fde983bcd62f7b5e769e60130 *RESOURCE/OPENING.SAN
b965b2753c541391e90396ab20f3bc96 *RESOURCE/SB010.SAN
b6167e556992b16fe68c628e40cb2f04 *RESOURCE/SB020.SAN
876086bf27ad1c9f1053992595bce7e9 *RESOURCE/SINKSHP.SAN
c25c4a1a0ebdcfa50f4027541b096326 *RESOURCE/VOXDISK1.BUN
ee1e9b7f1b2a91548cdc36d6137ab883 *RESOURCE/VOXDISK2.BUN
28fb6dbe5963aa28daf18584332ea0e9 *RESOURCE/WRECKSAN.SAN
711bd2711eefe4e3aec2a48021b81351 *RESOURCE/ZAP010.SAN
fe60d6b5ff51b0553ac59963123b5777 *COMI.LA0
09ae3abb98c43df89119466ae3557c0f *COMI.LA1
468f5ea61bb622284d57e615718b73cc *COMI.LA2

comment:6 by digitall, 6 years ago

Checked against mine and those MD5sums match my copy of CoMI too.

Tested with the attached savegame (in the Graveyard) and I can't spot any glitches or jumps in the music looping.

I am running the latest master: ScummVM 1.7.0git6150-g0b9ba6a-dirty (Mar 8 2014 23:40:20) Features compiled in: Vorbis FLAC MP3 ALSA SEQ TiMidity RGB zLib MPEG2 Theora AAC FreeType2 JPEG PNG

If you run "scummvm --version", you can copy the version you test with and the feature set to compare.

I also ran this with "./scummvm -d 1" and got the following: Debuglevel (from command line): 1 Using SDL Video Driver "x11" Using SDL Audio Driver "alsa" Output sample rate: 22050 Hz Output buffer size: 705 samples WARNING: SDL mixer output buffer size: 705 differs from desired: 2048!

comment:7 by SF/thunderpeel2001, 6 years ago

It appears to be working fine in the Nightly Build. Whatever it was appears to be fixed...?

That said, the music is still weird when you look at the painting of El Pollo Diablo.

comment:8 by digitall, 6 years ago

@thunderpeel2001: Would that be Kirben's latest nightly or the buildbot nightly? If it was buildbot, please also test with Kirben's to be sure. Thanks.

Hmm.. Weird in what way? I think it is meant to be "off putting" i.e. indicating the Evil of El Pollo Diablo! :)

Can you attach a savegame at or near the El Pollo Diablo painting so we can check the music there please? Also, can you try this with v1.6.0, v1.5.0 etc and see if the music has always been this way or if this is a recent change. Thanks.

by SF/thunderpeel2001, 6 years ago

Attachment: comi.s21 added

comment:9 by SF/thunderpeel2001, 6 years ago

I tested using the Kirben build.

As for El Pollo Diablo, it's much more boring I'm afraid :) The must jumps when you look at the painting, and then it restarts when you leave the close up. Weird and jarring!

Here's the save.

comment:10 by digitall, 6 years ago

Hmm... I can replicate that with your savegame, but I don't think that is a regression. I think the music has always done that... Can you test with the original Win32 CoMI executable to see how the original behaves please?

comment:11 by digitall, 6 years ago

If you do, please attach a savegame at this point from the original for comparison...

comment:12 by digitall, 6 years ago

Status: newpending

comment:13 by sev-, 4 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.