Opened 6 years ago

Closed 6 years ago

Last modified 14 months ago

#6506 closed defect (fixed)

AGOS: Engine detects, but does not work with, data files ending with a "."

Reported by: eriktorbjorn Owned by: lordhoto
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game:

Description

This may be more of a generic problem than a game-specific one. I'm filing a bug report to preserve the information posted in http://forums.scummvm.org/viewtopic.php?t=13490

There is a long-standing hack in File::open() where if it fails to open a file, it will try to open the same file again with a "." appended to the filename. Apparently this was added to handle some releases of Simon the Sorcerer, but the same thing could possibly affect other games as well.

However, this workaround has been semi-broken for the past few years. You can still detect the game, whether the file names end with "." or not, but ever since the engine gained support for reading files from InstallShield cabinets (I think that's what it does), it will no longer find such files while playing the game.

So I guess either the workaround has to be extended to cover both these cases or, if it's only actually needed for the AGOS engine, be made engine-specific. I'm not sure which is the most appropriate.

Ticket imported from: bugs/6506.

Change History (5)

comment:1 by lordhoto, 6 years ago

I implemented some changes to AGOS in the following pull request: https://github.com/scummvm/scummvm/pull/422 They should take care of this bug report (digitall at least confirmed they do).

comment:2 by lordhoto, 6 years ago

Should be fixed from aa87af50b21a7ce03433e108b690322d44dbbb45 on in master.

comment:3 by lordhoto, 6 years ago

Owner: set to lordhoto
Resolution: fixed

comment:4 by lordhoto, 6 years ago

Status: newclosed

comment:5 by digitall, 14 months ago

Component: Engine: AGOS
Note: See TracTickets for help on using tickets.