Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6507 closed defect (fixed)

RINGWORLD2: Can use objects that aren't yours

Reported by: eriktorbjorn Owned by: Strangerke
Priority: normal Component: Engine: TsAGE
Keywords: Cc:
Game: Return to Ringworld

Description

English CD version of the game

After Miranda was captured, I noticed that if I readied an object as Quinn (e.g. by clicking on his scanner or blaster or whatever), and then switched to Miranda, Quinn's object was still active and could be used by her.

I wasn't able to break the game this way, but it seems like the kind of thing that could cause trouble at some point.

Ticket imported from: bugs/6507.

Change History (9)

comment:1 Changed 6 years ago by Strangerke

Fixed in e59c652b4bb24b353ab9e867188de8c675045569

comment:2 Changed 6 years ago by Strangerke

Owner: set to Strangerke
Resolution: fixed

comment:3 Changed 6 years ago by eriktorbjorn

Seems to work now.

comment:4 Changed 6 years ago by eriktorbjorn

This bug seems to be back again. To repeat, all I had to do was:

1) Start the game afresh. (I hope you like the intro.)
2) Change to Seeker.
3) Click on Seeker's stunner.
4) Change back to Quinn.

Quinn can now use the stunner (though it's not, of course, in his inventory).

comment:5 Changed 6 years ago by eriktorbjorn

Resolution: fixed

comment:6 Changed 6 years ago by Strangerke

Resolution: fixed

comment:7 Changed 6 years ago by Strangerke

Fixed regression in a41db1939cdff632d16aa3849e23b844c46bafef

comment:8 Changed 6 years ago by eriktorbjorn

Status: newclosed

comment:9 Changed 6 years ago by eriktorbjorn

Seems to work again now.

Note: See TracTickets for help on using tickets.