Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6480 closed defect (fixed)

NEVERHOOD: Car glitches

Reported by: eriktorbjorn Owned by: johndoe123
Priority: normal Component: Engine: Neverhood
Keywords: Cc:
Game: The Neverhood

Description

When riding the car in "module: 2500, previous module: 2500, scene 8 (normal scene)" there are a couple of glitches. When the car reaches the end of the track, it's momentarily drawn in the wrong position, causing it to flicker.

When it enters/leaves at the bottom of the screen, there are often masking glitches. Perhaps related to the car turning around for no apparent reason when it enters?

From what I understand, the car is handled by module1600.cpp / module1600_sprites.cpp

Ticket imported from: bugs/6480.

Attachments (1)

neverhood-win.013 (19.7 KB ) - added by eriktorbjorn 6 years ago.

Download all attachments as: .zip

Change History (8)

by eriktorbjorn, 6 years ago

Attachment: neverhood-win.013 added

comment:1 by johndoe123, 6 years ago

Thanks for the bug report. It should be in the next daily build. The problem was an incorrect clipping rectangle.

comment:2 by johndoe123, 6 years ago

Owner: set to johndoe123
Resolution: fixed
Status: newclosed

comment:3 by eriktorbjorn, 6 years ago

I can confirm that the masking issues as the flicker is gone, but there's still that odd turn when you enter the scene. I didn't see that when I looked at a playthrough on YouTube, so maybe this is still a bug?

comment:4 by johndoe123, 6 years ago

I fixed a leftover from the clipping stuff before. I'm not sure if the car turn is a real bug. See e.g. http://www.youtube.com/watch?feature=player_detailpage&v=aTxBnZuLzUU#t=908 where this also happens and apprently uses the original exe.

comment:5 by johndoe123, 6 years ago

Resolution: fixed
Status: closednew

comment:6 by johndoe123, 6 years ago

Resolution: fixed
Status: newclosed

comment:7 by johndoe123, 6 years ago

Closed; the car seems to behave the same in the original when entering that room.

Note: See TracTickets for help on using tickets.