Opened 17 years ago

Closed 17 years ago

#640 closed defect (fixed)

MI2: Headless Guybrush in opening credit

Reported by: SF/jamieson630 Owned by: fingolfin
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

Halfway through the MI2 opening credits, where
Guybrush comes out and taps his foot until the
monkeys leave, Guybrush is entering stage left with no
head. Not until he gets all the way in and stops does his
head show up. I'm not sure, but I think he may not be
walking properly, either (i.e. he appears to sort of "slide"
into position).

This is a regression; it was not present in 0.3.0b official
release. I scanned CVS for recent changes that might
be responsible, but when I came across the massive
changes in gfx.cpp and the changes in akos.cpp, I got
the "eebie jeebies" and walked away. Sorry. ;-)

Ticket imported from: #655652. Ticket imported from: bugs/640.

Change History (5)

comment:1 by fingolfin, 17 years ago

I am responsible for the gfx.cpp changes, and IIRC erik for
the akos mods. But akos is only for V7 games, I think, so I
don't see how it should be his changes, which then according
to your findings would leave me as prime suspect (or rather,
my changes). I'll try to look into it when I have time. If
you can narrow this down to a particular checking, though,
that'd be helpful <g>. If not I'll manage, too, of course.

comment:2 by fingolfin, 17 years ago

Come to think of it, I also made a few changes to actor.cpp,
much more likely that caused it than anything in gfx.cpp

comment:3 by fingolfin, 17 years ago

The problem is caused since we now set 'frame'. Need to
figure out how to do this right.

comment:4 by fingolfin, 17 years ago

Owner: set to fingolfin

comment:5 by fingolfin, 17 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.