Opened 17 years ago

Closed 17 years ago

#639 closed defect (invalid)

DOTT: no 2nd "room" menus, colonial

Reported by: SF/thegreenzebra Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Day of the Tentacle

Description

Day of the Tentacle (with voiceovers) CD. 1.Jun 1993.
[US] English.

No savegame available since the game is being run off
CD (scummvm complains it can't write the auto-savegame
as well; maybe storing savegames in ~/.scummvm/gamename
would be a good idea?)

Since I just started using ScummVM, I have no previous
version to give a report about.

$ scummvm -v
ScummVM 0.3.0b
Built on Dec 17 2002 04:20:47

compiled with:

$ gcc -v
Reading specs from
/usr/lib/gcc-lib/i386-slackware-linux/2.95.3/specs
gcc version 2.95.3 20010315 (release)

on:

$ uname -a
Linux neo 2.4.20 #1 Sat Nov 30 16:41:29 EST 2002 i686
unknown

which is an AMD AthlonXP 2100+ with 256M DDR ram.

The problem is, once the game switches to Hoagie in
colonial times, exiting the initial area (or "room")
with the chronojohn switches scenes properly, but then
there is no menu at the bottom of the screen. The music
plays and the game acts as if it'd work, but you can't
click anywhere to make the character walk, nor pick
menuoptions (they aren't there)

Steps to reproduce (these are from memory; if there's a
problem, I can try to give a more detailed steplist
upon request):

start game. sit through all of intro (I sat through all
other cutscenes, btw).

bernard:
pick up flyer. pick up sign. pick up dime from phone.
enter office. pick up swiss bank account booklet. open
drawer. pick up booboo-b-gone. smile at camera. leave.
open grandfather clock.

cutscene(s).

bernard:
walk over to sludge-o-matic, turn it off. pick up super
battery plans.

cutscene.

hoagie:
look at outhouse (grody!), walk to next "room" towards
house.

cutscene with flag designs here.

cuts back to hoagie with no menus.

I'm no expert, but the flag cutscene is one of those
"Meanwhile..." cutscenes which is different from all
the others. Could that have something to do with it?

If I can provide any other information let me know.

Ticket imported from: #655443. Ticket imported from: bugs/639.

Change History (10)

comment:1 by SF/ender, 17 years ago

Component: Engine: SCUMM
Game: Day of the Tentacle
Keywords: script added
Owner: set to SF/ender

comment:2 by SF/ender, 17 years ago

This sounds like an override is getting stuck somewhere and not
terminating the cutscene.

Will see if I can reproduce it here :)

comment:3 by SF/ender, 17 years ago

Owner: changed from SF/ender to fingolfin
Resolution: invalid

comment:4 by SF/ender, 17 years ago

Okay, the problem is you are running it from a read-only medium.

Day of the Tentacle saves a temporary save-game to do these
cutscenes, which it then loads to restore the previous state.
Unfortunatly, as you cannot save in your current location - it
doesnt have anything to load, and the game gets stuck.

The solution is either to run the game elsewhere, or change your
savegame path to point to a writable directory. Use a
"savepath=/directory" option in your ~/.scummvmrc, or an
environment variable as mentioned in the README.

Fingolfin, can you check that "Save state failed" message and
see if you can make it display something like "Temporary State
Save failed - Game may freeze" when saveCompatible is set?

Thanks :)

comment:5 by SF/thegreenzebra, 17 years ago

I know this is more of a feature request than a bug, then,
but maybe you could test to see if the directory the game is
being run from is writable, and if it's not, change the
savegame directory to the homedir or something?

Expected behaviour for me would be for the game to put the
savegame in ~/.scummvm/save or something anyhow.

comment:6 by fingolfin, 17 years ago

Owner: fingolfin removed
Summary: TENTACLE: no 2nd "room" menus, colonialDOTT: no 2nd "room" menus, colonial

comment:7 by SF/khalek, 17 years ago

so can this be closed or moved to feature requests now?

comment:8 by SF/thegreenzebra, 17 years ago

Yeah, move it to the feature requests.

What're you doing working on Christmas Eve? (oh, wait, I'm
working on my game too!)

comment:9 by fingolfin, 17 years ago

Status: newclosed

comment:10 by fingolfin, 17 years ago

Feel free to open a feature request.

Note: See TracTickets for help on using tickets.