Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#6381 closed defect (fixed)

TUCKER: In 3rd part, "Use Peg" fails...So game uncompletable

Reported by: (none) Owned by: digitall
Priority: normal Component: Engine: Tucker
Keywords: Cc:
Game: Bud Tucker

Description

In the third part of the game, at Seedy Street, to go down to the sewer, you need to use the peg, because it is too smelly, Bud will use the peg with his nose. You do that simply clicking on the USE icon and then clicking on the peg from the inventory being at any part of the Seedy Street, what i mean, is that you cannot use the peg with any object, the only action to do is "use peg". It is a "special object" because that. That's why i think ScummVM has the bug...

Ok, so the bug is that if you do the use peg, ScummVM expects you select other object to interact with, so it shows "Use peg with", and if you click on the sewer, Bud does anything.
So, two possibilities can be done to fix this:
- Do as the original game: the peg can't be used with any object, simply you must click on USE icon and the peg (so if Bud is in any part of Seedy Street, he automatically will go walking to the sewer and will start the sprite animation).
OR
- Let the peg be used with any object, so we will do "USE peg WITH sewer", but, let the sprite animation start to complete the puzzle!

I think the first one is the best to be the same as the original game.

I attach a savegame from Dosbox to see the correct behaviour, and from ScummVM to see the bug.

This makes the third part be uncompletable! Please, fix it!

THANKS

Ticket imported from: #3614701. Ticket imported from: bugs/6381.

Attachments (2)

ScummVM_savegame_sewer_(manhole)_bug.zip (564 bytes ) - added by SF/*anonymous 6 years ago.
ScummVM savegame to reproduce the error
Dosbox_savegame_correct_behaviour.zip (788 bytes ) - added by SF/*anonymous 6 years ago.
Dosbox savegame to see the correct behaviour (simply do: USE peg)

Download all attachments as: .zip

Change History (12)

by SF/*anonymous, 6 years ago

ScummVM savegame to reproduce the error

by SF/*anonymous, 6 years ago

Dosbox savegame to see the correct behaviour (simply do: USE peg)

comment:1 by (none), 6 years ago

Priority: normalhigh

comment:2 by wjp, 6 years ago

Priority: highnormal

comment:3 by digitall, 6 years ago

Owner: set to cyxx
Summary: TUCKER: VERY IMPORTANT BUG: Third part uncompletableTUCKER: In Spanish variant, 3rd part, "Use Peg" fails...

comment:4 by digitall, 6 years ago

Unamed Google User: Thank you for the bug report. It may be some time before a TUCKER engine developer can look at this. Please be patient and stand by...

comment:5 by SF/mthreepwood, 6 years ago

cyx is retired, unassigning from him.

comment:6 by SF/mthreepwood, 6 years ago

Owner: cyxx removed

comment:7 by (none), 6 years ago

I edited the bug title to remove "spanish variant", because that bug ALSO HAPPEN IN THE ENGLISH VERSION, I have tested it. Thanks

comment:8 by (none), 6 years ago

Summary: TUCKER: In Spanish variant, 3rd part, "Use Peg" fails...TUCKER: In 3rd part, "Use Peg" fails...So game uncompletable

comment:9 by digitall, 6 years ago

Owner: set to digitall
Resolution: fixed
Status: newclosed

comment:10 by digitall, 6 years ago

Fixed in 91d551945646fe7fba290848454f900ca4670ad9.

This was a missing hardcoded case for the unary action of the peg.

Note: See TracTickets for help on using tickets.