Opened 10 years ago

Closed 10 years ago

#6360 closed defect (duplicate)

MONKEY2: Crash During "Dream Sequence"

Reported by: SF/sean123abc Owned by:
Priority: normal Component: Engine: SCUMM
Version: Keywords:
Cc: Game: Monkey Island 2

Description

The problem occurs during the dream sequence on Booty Island when Guybrush bashes his head on the plank when the oar snaps at the Big Tree. From what I can gather, they should perform several verses of the song, then there should be some indication that this song has been written on the spit encrusted paper. What happens in ScummVM is that they only sing one verse but they carry on dancing while the music plays, then the tune eventually finishes and they're still dancing. The only way to advance is to press the skip cutscene button, and then LeChuck appears.

This occurs on the android version of ScummVM. The phone I use is Samsung Nexus S

Ticket imported from: #3614580. Ticket imported from: bugs/6360.

Change History (6)

comment:1 by SF/sean123abc, 10 years ago

The game is Monkey Island 2

comment:2 by SF/mthreepwood, 10 years ago

Is it actually crashing or is it just not letting you continue without skipping the cutscene?

comment:3 by SF/mthreepwood, 10 years ago

Summary: Crash During "Dream Sequence"MONKEY2: Crash During "Dream Sequence"

comment:4 by SF/sean123abc, 10 years ago

Good point, I guess it's not actually crashing. It just keeps prolonging the cutscene indefinitely. I don't think there is a way of skipping the cut scene either...There is no escape key on the phone keyboard.

comment:5 by digitall, 10 years ago

This is another duplicate of the very long standing and very duplicate reported bug #2905877 "SCUMM: MI2 Dancing Skeletons cause Game Loop": http://sourceforge.net/tracker/?func=detail&aid=2905877&group_id=37116&atid=418820

The issue is that the script here is triggered on very specific beats of the MIDI and can get stuck due to timing/race issues.

Hopefully one of the SCUMM devs can investigate this and try to get a resolution... however, as it is a timing bug, trying to get a stable replication case to investigate is a bit of a PITA.

comment:6 by SF/mthreepwood, 10 years ago

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.