Opened 7 years ago

Closed 7 years ago

Last modified 22 months ago

#6359 closed defect (fixed)

GRAPHICS: Odd thumbnail sizes crash

Reported by: SF/dmwarren Owned by: lordhoto
Priority: normal Component: GUI
Keywords: Cc:
Game: King's Quest 6

Description

Game affected: King's Quest 6 (Macintosh, English)

Platforms affected: Confirmed on Mac OS X 10.8 and Debian 7.

Last known build with this bug ScummVM 1.7.0git564-gc7ec14d

Earliest known build with problem: ScummVM 1.6.0git1480-g9827c40

Earliest known build without problem: ScummVM 1.5.0 final

Reproducible: ~60% of the time/somewhat easily.

What triggers the crash: Load the Mac version of KQ6, start the game, and initiate a save right away. If it doesn't crash on the first try, walk to another screen and try again. ScummVM will crash somewhere in createThumbnail_2() after entering a savegame name and clicking "OK" to start the save:

scummvm(23992,0x7fff7b18f180) malloc: *** error for object 0x7f942d4b9608: incorrect checksum for freed object - object was probably modified after being freed. *** set a breakpoint in malloc_error_break to debug Abort trap: 6

Valgrind leakcheck output attached.

What should happen instead: ScummVM should not crash. ;)

Thanks for the ScummVM team's hard work. Let me know if you need more info or testing.

Ticket imported from: #3614568. Ticket imported from: bugs/6359.

Attachments (1)

kq6mac-scummvm160final-savecrash.txt (27.9 KB ) - added by SF/dmwarren 7 years ago.
Valgrind output

Download all attachments as: .zip

Change History (6)

by SF/dmwarren, 7 years ago

Valgrind output

comment:1 by SF/mthreepwood, 7 years ago

This is because our thumbnail code is exploding at at odd size (320x218 or so). Assigning to fuzzie because that's what fuzzie requested.

Also, King's Quest 6 Mac is not officially supported still :)

comment:2 by SF/mthreepwood, 7 years ago

Component: Engine: SCI
Game: King's Quest 6
Owner: set to fuzzie
Summary: SCI: KQ6 Mac: crash in createThumbnail_2 when savingGRAPHICS: Odd thumbnail sizes crash

comment:3 by lordhoto, 7 years ago

This should be fixed in the latest daily build. The commit which implemented the change is adf8cee449b42debbdc6578538a78127ada74cec. It was merged in 88c67c87672dcb2612612576560adcba7b29557a.

comment:4 by lordhoto, 7 years ago

Owner: changed from fuzzie to lordhoto
Resolution: fixed
Status: newclosed

comment:5 by digitall, 22 months ago

Component: GUI
Game: King's Quest 6
Note: See TracTickets for help on using tickets.