Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#6321 closed defect (wontfix)

GOB: Disappearing item

Reported by: (none) Owned by: DrMcCoy
Priority: low Component: Engine: Gob
Keywords: original Cc:
Game: Gobliiins

Description

In Scene 14: The Carrot Patch - code EWDGPNL
If you follow these steps:
- cast a spell on small stone (it grows into stairs)
- pick up Stick
- push a button with the Stick (Watering can appears)
- pick up Watering can
- use Watering can on the leftmost carrot (it grows a bit)
- cast a spell on the leftmost carrot (it raises from the ground, with a Key)
- punch the leftmost carrot
the Key falls down and carrot disappears into ground.

When the carrot disappears, the Stick also disappears (from where you left it).

Game version: DOS/English, both Floppy and CD (1.02) versions - versions distributed by GOG.com
ScummVM version: Debian 64bit latest development version - ScummVM 1.7.0git21-g43791c5 (May 8 2013 05:54:34) - also tested on version 1.4.1

Ticket imported from: #3612923. Ticket imported from: bugs/6321.

Change History (7)

comment:1 by wjp, 7 years ago

Summary: Disappearing itemGOB: Disappearing item

comment:2 by wjp, 7 years ago

Keywords: script removed

comment:3 by digitall, 7 years ago

Owner: set to DrMcCoy

comment:4 by digitall, 7 years ago

Keywords: original added
Priority: normallow
Resolution: wontfix

comment:5 by digitall, 7 years ago

RP: Have tested with the original interpreter running under DOSBox and the same behaviour occurs in the original. The stick is not necessary to complete the puzzle once you have the key, so this is not game breaking and is probably intended, so may be a "Not a bug"... Lowering priority as not a regression from the original interpreter or game breaking. If one of the Gob Devs has a look, we may be able to patch, but may not be worth it.

comment:6 by bluegr, 6 years ago

Moved to the known gob bugs page which also occur in the original (after talking with DrMcCoy):

http://wiki.scummvm.org/index.php/Gob/Bugs

Closing

comment:7 by bluegr, 6 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.