Opened 6 years ago

Closed 6 years ago

#6320 closed defect (wontfix)

GOB: Bee not cleared on loading in scene 12

Reported by: (none) Owned by: DrMcCoy
Priority: low Component: Engine: Gob
Keywords: original Cc:
Game: Gobliiins

Description

In Scene 12: Inside the Wizard’s House - code FTQKVLE
If you follow these steps:
- pick up Feather
- tickle skeleton's foot with Feather (Key falls down)
- pick up Cup and ball
- give Cup and ball to skeleton
- pick up Key
- give key to the Imp in cage (Imp opens cage and escapes)
after a while a Fly flies into the room and flies around.

If you reload the level at this moment, the Fly is still in the room flying around.

Game version: DOS/English, both Floppy and CD (1.02) versions - versions distributed by GOG.com
ScummVM version: Debian 64bit latest development version - ScummVM 1.7.0git21-g43791c5 (May 8 2013 05:54:34) - also tested on version 1.4.1

Ticket imported from: #3612922. Ticket imported from: bugs/6320.

Change History (10)

comment:1 by wjp, 6 years ago

Keywords: script removed
Summary: Reappearing item when loadingGOB: Reappearing item when loading

comment:2 by digitall, 6 years ago

Owner: set to DrMcCoy
Resolution: worksforme

comment:3 by digitall, 6 years ago

RP: Tried to replicate this with Floppy version with Original Interpreter under DOSBox and v1.5.0 with Floppy and CD versions on Win32 with no success.

I suspect this may be possible if you trigger the load exactly as the Bee (not fly) script is activated, but I can't do it and even if this occurs, I suspect the same would be possible in the original interpreter i.e. this is not a regression and has a low priority... If a Gob developer can have a look at this script and see if this is possible.

comment:4 by digitall, 6 years ago

Summary: GOB: Reappearing item when loadingGOB: Bee not cleared on loading in scene 12

comment:5 by (none), 6 years ago

I tried to reproduce it again and it seems to be dependent on the position of the bee.
What seems to work everytime, is reloading when the bee sits on the top shelf. The bee is not immediately visible (after reload), but it appears when it flies away from the shelf.

comment:6 by digitall, 6 years ago

RP: OK. Replicated with v1.5.0 on Win32, but have tested with the original interpreter running under DOSBox and the same behaviour occurs in the original. Lowering priority as not a regression from the original interpreter, but a game script bug... If one of the Gob Devs has a look, we may be able to patch, but may not be worth it.

comment:7 by digitall, 6 years ago

Keywords: original added
Resolution: worksformewontfix

comment:8 by digitall, 6 years ago

Priority: normallow

comment:9 by bluegr, 6 years ago

Status: newclosed

comment:10 by bluegr, 6 years ago

Moved to the known gob bugs page which also occur in the original (after talking with DrMcCoy):

http://wiki.scummvm.org/index.php/Gob/Bugs

Closing

Note: See TracTickets for help on using tickets.