Opened 6 years ago

Closed 13 months ago

Last modified 5 weeks ago

#6185 closed defect (worksforme)

ANDROID: Crash when (un)plug keyboard on Asus Transformer

Reported by: SF/vpelletier2 Owned by: dafioram
Priority: blocker Component: Port: Android
Keywords: Cc:
Game:

Description

SCUMMVM versions tested:
- 1.5.0 from app store
- 1.6.0git2052-g46348e7 from daily builds

Android 4.1.1 (ASUS build: JRO03C.WW_epad-10.4.4.20-20121026), on TF700T.

How to reproduce:
- Start scummvm until game list is shown. Optionally start a game or bring up a dialog.
- Plug or unplug keyboard: after ~2s you should be back to home screen.
Restoring scummvm restarts the app (black screen for ~10s, then main menu is displayed)

I believe scummvm crashes rather than just being sent to background, because on the recent app list the preview is blank. When sending scumvm to the background manually, a screenshot is visible and restoring often works (though not always - but that is another bug which I didn't try to reproduce on 1.6 yet).

Ticket imported from: #3586310. Ticket imported from: bugs/6185.

Attachments (1)

scummvm.log.gz (7.8 KB) - added by SF/vpelletier2 6 years ago.
logcat

Download all attachments as: .zip

Change History (12)

comment:1 Changed 6 years ago by digitall

Summary: ASUS transformer: scummvm crashes when (un)plugging keyboardANDROID: Crash when (un)plug keyboard on Asus Transformer

comment:2 Changed 6 years ago by digitall

vpelletier: It would be useful if you could manage to get the relevant logs at this point to help determine what is happening:
https://developer.android.com/tools/help/adb.html#logcat
and attach them to this bug as a zipped text file.

Changed 6 years ago by SF/vpelletier2

Attachment: scummvm.log.gz added

logcat

comment:3 Changed 6 years ago by SF/vpelletier2

Attached.

comment:4 Changed 6 years ago by digitall

Owner: set to fuzzie

comment:5 Changed 6 years ago by digitall

vpelletier2: Thanks.

Looking at the log, the relevant section appears to be:
D/ScummVM (29492): surfaceCreated
D/ScummVM (29492): surfaceChanged: 1920x1128 (4)
I/ScummVM (29492): ScummVM 1.6.0git2052-g46348e7 (Nov 10 2012 04:11:12)
F/ScummVM (29492): Assertion failure: '!_system' in ../../src-master/src/backends/platform/android/jni.cpp:426 (static void JNI::create(JNIEnv*, _jobject*, _jobject*, _jobject*, _jobject*, _jobject*, jint, jint))
F/libc (29492): Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1), thread 29535 (ScummVM)

comment:6 Changed 6 years ago by digitall

fuzzie's analysis:

"The log clearly shows that we get an onDestroy on the activity, so the bug is that we don't actually shut down completely there. The documentation implies we can check isFinishing() to see if we actually got permanently destroyed, so maybe we should leave ScummVM running in that case."

Looking at replicating and will see if we can fix...

comment:7 Changed 13 months ago by csnover

Component: Ports

comment:8 Changed 13 months ago by csnover

Priority: normalblocker

Raising all identified crasher, hang, and memory violation bugs which I could not fully triage myself to blocker priority for the next release.

comment:9 Changed 13 months ago by csnover

Owner: fuzzie deleted

Removing all owners from release blockers so they can be reclaimed during the release process. If you are the previous owner and would graciously fix this bug for the next release, please go ahead and re-add yourself as owner.

comment:10 Changed 13 months ago by dafioram

Owner: set to dafioram
Resolution: worksforme
Status: newclosed

I am able to disconnect and reconnect my Bluetooth keyboard (#6880) both in game and at the gui and no crash happens. The keyboard works as intended. This is on my asus transformer prime tf201 on scummvm 1.9.0.1. Android version 4.1.1.

comment:11 Changed 5 weeks ago by digitall

Component: PortsPort: Android
Note: See TracTickets for help on using tickets.