Opened 4 years ago

Closed 2 years ago

Last modified 12 months ago

#6880 closed defect (duplicate)

Android: Crashes on BT keyboard (dis)connect

Reported by: SF/chobits Owned by: csnover
Priority: normal Component: Port: Android
Keywords: Cc:
Game:

Description

Running nightly scummvm, todays release.

When my bt keyboard connects or disconnects scummvm crashes.

07-25 20:38:13.771 F/ScummVM (16655): Assertion failure: '!_system' in ../../src-master/src/backends/platform/android/jni.cpp:385 (static void JNI::create(JNIEnv*, jobject, jobject, jobject, jobject, jobject, jint, jint))

Semi-related. Sometimes the video in riven will stick (can happen when a toast pops up). And if you press the projecter button in the temple it crashes (or did for me).

Ticket imported from: bugs/6880.

Change History (6)

comment:1 by SF/mthreepwood, 4 years ago

(Riven is not supported.)

comment:2 by fuzzie, 4 years ago

Owner: set to fuzzie

comment:3 by fuzzie, 4 years ago

Auto-rotation causing us to lose the activity? The code here is clearly broken..

Which device and Android version is this?

comment:4 by sev-, 3 years ago

Component: --Unset--Ports

comment:5 by csnover, 2 years ago

Owner: changed from fuzzie to csnover
Resolution: duplicate
Status: newclosed

Duplicate of #6185.

comment:6 by digitall, 12 months ago

Component: PortsPort: Android
Note: See TracTickets for help on using tickets.